Jump to content
Flirc Forums

Long press with Kodi


Recommended Posts

I am trying to configure FLIRC USB v2 with Kodi.  It is all working fine apart from being able to use long-press of the Enter key to access the Context menu.  I am using an LG Magic Remote programmed to emulate a Samsung Blu-Ray remote. 

If I use the original Samsung remote and long-press the Enter key, the context menu in Kodi appears ok. 

If I use the LG Magic Remote and long-press the Enter key it just acts like a short press of the Enter key. 

I think I need to assign the 'C' key to the long press of the Enter key but whenever I try and assign a command to the long-press of the Enter key I get a message indicating that it is expecting the second key (macro?).  I can successfully program a number key on the remote to be the C key which opens the context menu.  I just cannot get the long press to work.

What I want is:

short-press of Enter key = Enter key on the keyboard

long-press of Enter key = C key on the keyboard




Link to comment
Share on other sites

It seems that there are limited functions that the long press can be applied to and the C key is not one of them.  So I have changed my Kodi keymap so that the context menu isnow accessed by pressing the Tab key instead of the C key.  I used the long press on the Enter key of my remote to map to the Tab key.  It accepted it ok.  I also mapped some of the numeric buttons on my remote to the Tab key.  If I long press the Enter key on the remote Kodi will still not open the context menu.  If I press one of the numeric keys on my remote that I mapped to Tab, the context menu does open ok.  This long-press function is proving very difficult to get to work

Link to comment
Share on other sites

I have tried using Notepad as a test.  Pressing the numeric buttons I programmed as Tab enters a tab into the document.  Long pressing the Enter button just creates a new line in the document just as short pressing the Enter does.  So the problem is that the long press is not  being recognised as being different to the short press. Below are my settings.  Can anyone help me work out why the long press of the Enter button is not sending the Tab?  I think index 6 is the recorded long press of the Enter button

I have a feeling the problem may be the remote.  The TV recognises long press of the buttons that are not programmable ones.  Eg the Settings button on the remote does two different things for long and short press.  But I think these buttons are using Bluetooth (not IR) to send to the TV.  

When it is emulating the Samsung Blu-Ray player remote, the programmable buttons  on the remote send IR commands.  Perhaps the remote doesnt recognise a long press of these buttons any differently to a short press?

C:\Program Files (x86)\Flirc>flirc_util.exe settings

FW Version: v4.9.3
   SKU:     Flirc 2.0 [dori]
   Branch:  master
   Config:  release
   Hash:    0xCB185BDE

  sleep detection:  always enabled
  noise canceler:   always enabled
  inter-key delay:  N/A for current firmware
  variant:          Flirc
  builtin profiles: NA
  Memory Info:      NA
  product sku:      Flirc 2.0 [dori]

Recorded Keys:
Index  hash       IK   ID  key
-----  --------   ---  --  ------------
    0  1A957E77   123  01  up
    1  AA721077   130  01  down
    2  16022277   130  01  left
    3  86259077   123  01  right
    4  DEF91077   124  01  return
    5  080EA277   123  01  backspace
    6  DEF91077   000  01  tab
    7  E663EC77   123  01  tab
    8  76407E77   123  01  tab
    9  3F376C77   124  01  tab
   10  B8BAFE77   123  01  e
   11  2CD57E77   123  01  e
   12  48979077   123  01  x
   13  F84E7E77   123  01  x
   14  D401FE77   123  01  i

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...