Jump to content
Flirc Forums

firmware error after upgrading to v3.25 GUI and 3.11 firmware


Recommended Posts


After updating  my the flirc streacom edition (I think is gen1) to firmware 3.11 keypresses don't work anymore.  Flirc seems to be connected with the flirc software as I can record presses, but they don't work on windows 10.

I tried to reinstall the drivers several times and I noticed the flirc interface 1 is working fine using the libusbk driver, but the problem seems to be on the flirc interface 0 driver. It gets recogniced as and USB input device, but it throws and error 10:


This device cannot start. (Code 10)

An unknown item was found in the report descriptor.


I tried several drivers using zadig, but I couldn't solve the issue.

Can you please help me with the issue or send me the firmware file to downgrade the firm to a working version?


Link to comment
Share on other sites

I don’t think the downgrade will help, but we can try it. Can you show me the device manager. There are two interfaces, interface 0 and interface 1. You do not want interface0 to be assigned by ZADIG. You want to remove that so that windows installs the default HID driver.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...