Jump to content
Flirc Forums

IR Debugging shows output, but flirc not working in windows?


Recommended Posts

I just bought a Flirc (v2) because it said "works with any remote", which would mean that I could use my old MCE remote that I can't find drivers for anymore, but no luck. I can see things happening in the debug window and the gui reacts when I map buttons, but nothing else seems to notice the remote. Kodi doesn't react, no output in notepad etc. Am I missing something? Is the remote too old (I tried the remote for my projector, same thing happens), despite the tag line? Is something else wrong? Thanks.

Windows 10, trying to control Kodi. This happens when I press the "down" button three times:














Link to comment
Share on other sites


Flirc v2 has a built in support for MCE remote, but it's not a direct replacement for the original MCE receiver.

Flirc is seen as an USB keyboard in the system. That means that for Flirc to work with some software, it needs to know how to map a button press on the remote to some keyboard function or letter. As I mentioned above, Flirc has a built-in profile for MCE remotes and it should at least do something in the Kodi or notepad, but it's not meant to use with Kodi.

You can try following. In the Flirc GUI, go to Advanced settings and actually disable available built-in profiles then close advanced settings dialog. In the GUI's menu select Controllers and Full keyboard. Click some letter (for example A) on a virtual keyboard in the Flirc program - it should ask you to press a button on the remote. So press one of the buttons - but don't just quickly press and release, it's better to hold the button until the message disappears.

Then do a test in the notepad. Press the same button you've recorded few times when the notepad window is active. It should print the letter a. If you followed everything above then probably letter a is only showing every other press on the remote. That's because MCE IR protocol changes signal a little between every other key press (it has a toggle bit). This means that you should actually repeat programming two times for each remote button in the GUI (for example, click on Up Arrow in the GUI, press Up button on the remote, click on Up Arrow again, and again press the button).

Link to comment
Share on other sites

Hi. Thanks for your answer. I put the flirc in my big workstation, and there it seems to be working - notepad receives the input - but I can't get it to work on my HTPC, which is where I need it. It's a newly installed windows 10 pro, so not a lot of driver garbage etc. Same problem as before, the gui says connected and I can map keys, but nothing else sees the input. What could be wrong? What can I try next?

Link to comment
Share on other sites

Crap. I moved my HTPC from the spot by the modem/router, where I aso keep a bunch of NASes and receivers and stuff and now it works. So, too much interference. The problem is that there is nowhere else to move the HTPC, since it has to be connected to sound, HDMI and the internet by cable. Is there some way to shield the Flirc somehow? Would a USB extension cable help?

Edit: Found an old usb hub with a long extension cable that worked before I moved the HTPC back, but it still won't work when I put the HTPC in it's original place, even though the flirc is almost 2 meters away from the interfering stuff.

Edited by monkeybrother
Link to comment
Share on other sites

Did you use the same USB cable to the hub before and after moving the HTPC? Interference issues may be hard to handle. Is all your equipment properly grounded? This includes a ground connection in your mains socket, extension cords/power strips etc. Maybe that's an electrical issue, some EM interference.

Some people had some problems with the older 1st gen Flirc, when their equipment wasn't grounded and properly grounding the installation helped resolving the problems. There were no such issues with 2nd gen but may still be possible.

Link to comment
Share on other sites

Yes, same cable, I just moved the whole thing and plugged it in. None of my equipment is grounded... the building is from the 40's or 50's and only the kitchen is updated/grounded, so I can't do anything about that. Wifi can't be the cause, at all? When I turn on wifi on my htpc (an msi cubi n), the remote stops working, even when the HTPC is in a "non-interfering" part of the house.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...