Jump to content
Flirc Forums

Flirc GUI fails to launch on Mac 10.10.5


Recommended Posts

I'm super excited about your product letting me keep the old Harmony.  I also love that you are a small start-up company.  I have my Flirc plugged in to the FireTV stick rev2 via the proper cable and configured with my Harmony 700.  Great product!  It works well so far.  Would totally recommend it.  Unfortunately though, I cannot launch this Mac GUI application to check for updates.  Maybe I am missing something?

On flirc.tv I click on Downloads and then Mac.  I am only presented with one option for download.  I checked the T&C checkbox and downloaded the .dmg and mounted the image.  Of course Mac OS says "not a recognized developer" which is understandable.  I went into Security and Privacy in the control panel and under General I chose to allow apps downloaded from anywhere.  Then I am able to attempt to launch the application.  I get a Problem Report for Flirc window every time I try.  I tried downloading again, replacing the previous Flirc in Applications and still get the same message.  removed Flirc from USB and ejecting the .dmg did not help either.  How am I the only one with this issue??

Thank you in advance.  The contents are as follows.

Process:               Flirc [69114]
Path:                  /Applications/Flirc.app/Contents/MacOS/Flirc
Identifier:            com.flirc.Flirc
Version:               ???
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Flirc [69114]
User ID:               501

Date/Time:             2018-09-14 19:17:16.950 -0500
OS Version:            Mac OS X 10.10.5 (14F2511)
Report Version:        11
Anonymous UUID:        B4A03C3B-4265-64CA-1D64-1530A471D356

Time Awake Since Boot: 5800000 seconds

Crashed Thread:        0

Exception Type:        EXC_BREAKPOINT (SIGTRAP)
Exception Codes:       0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: @executable_path/../Frameworks/libhidapi.0.dylib
  Referenced from: /Applications/Flirc.app/Contents/MacOS/Flirc
  Reason: no suitable image found.  Did find:
    /Applications/Flirc.app/Contents/MacOS/../Frameworks/libhidapi.0.dylib: code signature invalid for '/Applications/Flirc.app/Contents/MacOS/../Frameworks/libhidapi.0.dylib'

    /Applications/Flirc.app/Contents/MacOS/../Frameworks/libhidapi.0.dylib: code signature invalid for '/Applications/Flirc.app/Contents/MacOS/../Frameworks/libhidapi.0.dylib'

Binary Images:
    0x7fff6ad51000 -     0x7fff6ad8792f  dyld (353.2.4) <3C068A0D-69D5-3AD6-86D9-6261D3B1564E> /usr/lib/dyld

Model: Macmini5,3, BootROM MM51.0077.B15, 4 processors, Intel Core i7, 2 GHz, 16 GB, SMC 1.77f0
Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1333 MHz, 0x857F, 0x483634314755363746393333334700000000
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1333 MHz, 0x857F, 0x483634314755363746393333334700000000
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xE4), Broadcom BCM43xx 1.0 (
Bluetooth: Version 4.3.6f4 17916, 3 services, 18 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: Samsung SSD 850 EVO 120GB, 120.03 GB
Serial ATA Device: APPLE HDD HTS727550A9E362, 500.11 GB
USB Device: Hub
USB Device: Hub
USB Device: Apple Cinema Display
USB Device: SimpleDrive mini
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
USB Device: Hub
USB Device: flirc
USB Device: Microsoft Wireless Optical Desktop® 2.10
USB Device: IR Receiver
Thunderbolt Bus: Mac mini, Apple Inc., 22.2


Edited by CJohansen
updated with new information that the device functions, just the software fails.
Link to comment
Share on other sites

  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...