Jump to content
Flirc Forums

FLIRC Issues


Recommended Posts

I have the Flirc Streacom edition plugged into my media server. Was updating a few things today, small SSD drive and decided to give Ubuntu a try, but, nothing seemed to work... uninstalling LibreOffice fails, updates wouldn't work, couldn't get the Flirc install to work either. Never used Ubuntu/Linux before, but I know how to follow directions... just odd errors and such. 

Finally gave up, and tried OpenEllec instead. Installed, booted into KODI, no problem, but couldn't figure out how to get to the OS to install Flirc. 

Figured, if what I read was true, I could just hook up the old drive, boot into Win7x64, install and setup Flirc with that, because from what I read, the chip on the Flirc itself saves the keypress info. But, I'm still having issues.

I'm still in Win7. Until it's working perfect with Kodi I don't want to swap the drives around.

I setup the remote using Kodi under controllers, and surprised at how many keys that I use daily are missing. I guess I'll have to use full keyboard and in Kodi remap the key functions from there?

Main 2 issues though are

1) Every other time I go into Kodi, one or two buttons don't work. I go back to the Flirc setup screen, and most buttons say 'button already exists' but always one or two that aren't setup even though I had them setup and working. It seems that after a restart, or just over time I'm not certain, the Flirc forgets a few buttons. Since not a USB Flirc, I can't fix that easily once I switch drives around if it forgets again.

2) Power off/on doesn't work. I mapped the PWR button on my remote (Sony RM-VZ320) and saved... but when I click the button while the system is on, I get a Windows 'ding' noise. When the system is powered off, there is a (very) bright blue LED on the board that remains on, so getting power, but when I click PWR, nothing happens at all. Case PWR button works fine.

Any ideas? I need to get the power on/off working, and make sure that once programmed, Flirc doesn't keep forgetting random buttons.

Link to comment
Share on other sites

1) This should not happen. But there may be an issue with a specific remote. There may be some remotes that don't work that well with Flirc. From what I can see the remote you're using have some capabilities of universal remotes. You can set it to control different equipment. I would suggest you to try some different codes and check if it works better and is more stable.

2) How did you record the power button? Using the GUI or the command line tool? The GUI doesn't support Flirc-SE's power button capability at this time. It's because both Flirc USB (old one) and Flirc-SE share the same firmware and most of the hardware (SE only adds few elements needed for power button emulation). There's no easy way to differentiate between these two models in the GUI and show the Power button only when Flirc-SE is connected. We're thinking with Jason on how to implement this.

Right now, to record the Flirc-SE power button you need to use command line utility flirc_util.exe (it's in the Flirc's install folder). You need to start the cmd.exe, change current directory to Flirc's folder and then run

flirc_util.exe record power

and then press your power button on the remote. Also make sure you're using latest software and firmware version.

Sorry for asking the obvious but have you connected your power button through the Flirc-SE?

As for the OpenElec and Flirc GUI, I can't help you much with that as I've never played with OpenElec. From what I know, it's now built around any other Linux distribution, but it's created from scratch just for running Kodi. So there's probably no desktop environment at all. But you should be able to upload a standard Linux binaries and then run them in terminal (command line) using SSH. I think it should be possible to upload flirc_util binary and use it to configure Flirc (from command line) running OpenElec.

Link to comment
Share on other sites

Excellent... that worked, was able to power off/on.

Forced an upgrade for firmware and haven't had the vanishing buttons occur yet, been watching a TV show, shutting down, powering on and testing again, watch a show and repeat to see if anything happens. Few more times and I can swap the drives out. Tested in OpenElec and seems to be working great there as well. :)

Remote wise, there are a few buttons on there that EventGhost detected and was able to assign when I used that app, that this doesn't seem to detect at all. But for the most part, using the KODI screen to assign most buttons worked, then switched to KEYBOARD and using the Wiki page for keymapping for Kodi, I just assigned a few of the extra buttons on my remote to letters on the keyboard and I think I have about 90% of what I had before. Which is fine... powering on/off with a remote trumps the missing buttons. :D

Edited by THRobinson
Link to comment
Share on other sites

The different controllers in Flirc GUI are just sets of predefined keyboard shortcuts in the form of buttons labelled as specific functions. For example, from the point of view of the Flirc hardware, there's no difference at all whether you record either an Info button on Kodi controller or a letter i on a keyboard controller. It will store the exact same thing, because Flirc basically acts as a keyboard in the end.

As you already know, you can just look at the Kodi wiki page to check default Kodi keymap and record specific shortcuts for the functions you need. But you can also add your own keyboard.xml file in Kodi that modifies and extends default keymap and assign your own shortcuts to a lot of other functions that are not accessible directly from the keyboard by default. Then you can record these new shortcuts in Flirc as well. For example, I've added a shortcut for subtitle delay control so I can easily adjust misaligned subtitles without going into playback menus (single press on specific button pops up the subtitle delay slider where I can adjust the delay using left/right buttons).

Link to comment
Share on other sites

Well, so far so good, everything works except 1 or 2 things.

Current one I'm stumped on is that I assigned a button on my remote the key "M". When watching a video, if I click that button it brings up the file list the video was from.

But, if I use my Rii keyboard and click "M" the OSD pops up with the menu bar at the bottom for a few functions like downloading subtitles, changing the screen setting, etc... which is what "M" is supposed to do. So a bit stumped on that one... "M" on the remote envokes ??? (haven't figured it out yet) and "M" on a keyboard brings up the correct screen as per the Kodi Wiki keymap page.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...