Jump to content
Flirc Forums

firmware forray flumoxed functioning Flirc

sgt panties

Recommended Posts

Hi, I inserted a Flirc that I bought new about 6 months ago into my new
Windows 10 machine, then downloaded and installed the Flirc GUI.

I was having problems deleting an assignment when I decided to upgrade the
firmware.   I was also looking in the registry to see if I could find if
Flirc stored key assignments there.   I "forced" the firmware upgrade even
though I don't know why the regular upgrade firmware button was grayed out.
The registry editor crashed on a search (which is a known Windows 10 problem)
then something went wrong with the firmware upgrade, can't remember exactly

I admit it was pretty stupid doing anything simultaneously with a firmware

Now the GUI immediately craps out.  Device manager says the Flirc isn't
plugged in even though it clearly is.   The bootloader seems happy.

Attached is the level 5 log.

To own a Flirc is so frugal, I just went ahead and assumed my Flirc is
fried, and fetched a fresh facsimile from Amazon.  I'll follow up first thing
after it fulfills.



Link to comment
Share on other sites

I no longer feel as flippant.   It turns out it is not my fault.  I inserted the new Flirc from Amazon I received today and fired up the GUI.   The GUI stayed up which is an indication that the new Flirc was good and recognized.   I read the online instructions for upgrading the firmware and did so.  (Again, I do not understand why I had to use the "force" button rather than the update firmware button but so be it.)   Flirc chewed on something for a few seconds then "stopped working".   From that point on it is like my initial post and so is the log.

I recently discovered the "firmware bugs" forum.   If you would like to refile this post there please go ahead.   One post very similar to mine there is simply marked "resolved", with absolutely no explanation as to how.

I'm an ex programmer and I run a fairly tight ship with my Windows 10 system, meaning that I'm clean, completely functional, secure and up-to-date.  The only thing I that is out of the ordinary for a Windows 10 user is that I run EMET which is a special MS anti-virus program.

I have just bought my third Flirc because of this firmware problem.

Edited by sgt panties
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...