Jump to content
Flirc Forums

LRIC Windows GUI - Is There a Trick


Recommended Posts

Just installed FLIRC Windows GUI Version 1.3.6. After restart, FLIRC drivers are okay and I can see my FLIRC in the device manager (Windows 7 x64). But the FLIRC GUI will not fire up. It seems to try to start but never does. No error messges, nothing. Tried running as Admin, same result.


So, is there  asecret to getting the GUI working or do I just have an attractive dongle that I can't program? Troubleshooting tips welcome.

Link to comment
Share on other sites

Okay this is fun. Or maybe not,


Got the GUI to actually work (0.96 anyway) by building an XP VM and then running the installer there. Lo and behold, it actually finds the device despite there being a hypervisor between the app and the device.


I guess as long as never want to upgarde the firmware I'm fine, since this version of the GUI wants a firmware file to updgrade, which doesn't exist any more. Still a crappy expereince when the GUI doesn't work on Win7 for unknown reasons. I'll resist the urge to rate this product on AMZN for now.

Link to comment
Share on other sites

I'm sorry you've had such experience so far, but to be honest I don't remember anyone reporting such issue before. There may be something on your system preventing application to start. I have Flirc software 1.3.6 installed on my Windows 7 and it works very well.


If you can please share more details on your OS (32 or 64 bit, which edition). Is it fully updated from Windows Update?

Link to comment
Share on other sites

The OS is Windows 7 Ultimate 64-bit SP1 fully updated via Windows Update.


The Event Log shows some form of VC++ runtime issue:


Faulting application name: Flirc.exe, version:, time stamp: 0x54f4fb86
Faulting module name: msvcrt.dll, version: 7.0.7601.17744, time stamp: 0x4eeaf722
Exception code: 0xc0000005
Fault offset: 0x0000980a
Faulting process id: 0x2618
Faulting application start time: 0x01d0bb880fa241d2
Faulting application path: C:\Program Files (x86)\Flirc\Flirc.exe
Faulting module path: C:\Windows\syswow64\msvcrt.dll
Report Id: 4d9b9deb-277b-11e5-98f3-005056c00008

Link to comment
Share on other sites

I'll let Jason know about the problem.


In the meantime can you try working with CLI util? It's in the Flirc installation dir and it's called flirc_util.exe. Because of some strange bug you need to use full exec name in CMD (flirc_util.exe instead of just flirc_util). You can fully program your Flirc using the CLI.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...