Jump to content
Flirc Forums

Seems to Record/Program Perfectly, but then Doesnt Work


Recommended Posts

I've got a new FLIRC last week, first one, think its brilliant. On first programming, out of the box, basic template, it programed and worked perfectly in XBMC. I subsquently attempted to program more keys for XBMC, which appeared to program fine, but then subsequent use in XBMC yeilded zero response, even the keys that worked previously. As I tried to Clear the Configuration and re-program, I received a number of errors that looked like bugs, so on guideance from this forum I updated the firmware, then to 3.1. Since the update, the GUI appears to work perfectly; I run the programming processes, press remote keys, and the Gui responds immediately that its programmed perfectly, yet when I go to XMBC or wherever, the Apps completely ignore key presses from the remote. On top of that, when I go back to the Gui and attempt to re-program, the Gui does NOT tell me the keys are already programmed, or force me to erase them. Its almost as if the programming isnt being written to the device. I forced the firmware to 3.3 today, and results are exactly the same. When I unplug the FLIRC, the Gui detects is unplugged, and when I plug is back-in, it detects connected. No errors or issues installing drivers or firmware updates. Honestly, it acts 100% perfectly, from a setup standpoint, but just wont actually work inside any Applications.

Using Win7, and have tried on two different PC's, with identical results. Using an RCA universal remote.

Super-appreciate any ideas or suggestions. Thanks.

Link to comment
Share on other sites

A quick update to this. I also have a laptop running Linux, latest version of openSUSE. I downloaded and installed the Linux GUI and when I run it, it reports "unsupported firmware, try upgrading" while the firmware version at the bottom-left reports v3.3. Was hoping maybe Linux GUI would solve it, but no luck.

Link to comment
Share on other sites

I am having the same problem here. I just got my first FLIRC, purchased from Amazon and find it great the way it installs and goes. I just set it up on thursday afternoon.


My HTPC is running WinXP, just a temporary setup as I am having problems with my hauppauge hvr1600 and Mythbuntu working right.


I have a harmony 300 that I setup with I believe a panasonic TV profile, I setup FLIRC on a Win8.1 laptop. It worked fine with the setup using standard keyboard layout in FLIRC setup, my testing on XBMC worked great. I put it to sleep and later that night after putting the kids to bed I turned it on using the wake key I programmed. The wife and I sat down to watch an episode of The 100 we recorded and everything was fine until I paused it. Sitting back down an hitting playing made it go haywire, and she just gave me a frustrated look. I kept pausing and unpausing repeatedly. I ended up unplugging it and just controlled XBMC from my browser that night.


The next day I browsed the forums and did a force firmware upgrade on WinXP (now at 3.3), and set my key-inter delay to 6; this seemed to stop the endless keypresses even though it's not very responsive. This is when I started having the problems with the programmed keys not working. When I would go back into FLIRC setup and program the keys again most were no longer showing as having been previously programmed. After recording all my keys, I opened up XBMC and ran some tests, the keys were not programmed again.


After this I put i back in win8.1 laptop and re-programmed FLIRC with all new keys and am now having intermittent problems with it. It doesn't like to wake up unless it's been in standby for at least 1/2hr and most times I have to press a key multiple times to get any response.


We do have all LED light bulbs in our house and some threads I have read had people place a cloth over flirc and the remote and it worked fine. I amgoing to try this an report any change. Since we have the same problem here I am sharing what I have done to try and fix some of my problems and hoping we can figure this out. Another thing I have noticed is that most of my problens seems to occur after the HTPC returns from sleep.

Edited by gostmn26
Link to comment
Share on other sites

  • 4 weeks later...

I am also a new user and have the same trouble. The Flirc GUI says the keys are programmed fine, but the remote does nothing in windows 7 when I try to use it.

I updated the firmware to 3.3 to no avail. I also tried two different remotes. The GUI says the button presses record fine, but nothing happens when I use the remote with windows.


Edited by stampee
Link to comment
Share on other sites

  • 2 weeks later...

I have this same issue, and I was hopeful there might be a solution already in this thread.


My target: run NextPVR on a Lenovo Q190 (Win 8.1) from a Sony universal remote.


Symptom 1: GUI reset failed. I plugged the Flirc in, installed the GUI, programmed a few buttons from the remote, made a few errors and needed to start over. Reset worked the first time I needed it, but I was an idiot and made errors the second time too. My second reset seemed to work, but then the GUI kept giving me errors about keys already in use, so it clearly had not.


Attempted solution 1: Update firmware.


Symptom 2: GUI crashed. I tried the "Force FW upgrade", and it said my (amazon purchased) flirc was on 2.0 and would upgrade to 3.x (don't remember the number). Then the GUI crashed. If I unplugged the flirc, the GUI was fine, but if the Flirc was plugged in the GUI crashed.


Attempted solutions 2: Remove and re-install GUI - no dice. Manually update driver via windows - no dice. Manually update driver via zadig - no dice. Take the Flirc to my Win7/64 machine, install GUI, update driver via zadig (for both interface 0 and interface 1 - had to do both or it wouldn't work), update firmware (which appeared to fail when the GUI quit responding to windows and had to be shut down but was a.....) - Success! GUI talks to the flirc on both machines.


Symptom 3: Flirc responds to the Sony remote in GUI, but not anywhere else. Not even intermittently. Absolutely nothing outside of the GUI programming responses.


Attempted solutions round 3: Switch computers - nadda. Close GUI - nope. Unplug Flirc and plug back in - zippo. Unplug Flirc and Logitech unifying, then plug back in - nyet. Try 3rd computer (Win 7/64 laptop) without the GUI - nein. Zadig installed drivers on the 3rd computer - non. Change Inter-key delay - no change.


The Flirc sounds like a neat device that should be a perfect fit for my target use. But I'm not off to a promising start. It's not even heavy enough to be a paperweight ;-)

Link to comment
Share on other sites

  • 2 weeks later...

Followup with a resolution to my symptoms.


I used the flirc contact form and Jason got back with me a couple of days later.


Review of my symptoms at the time of contact:

 - GUI only interacted with the flirc when both interface 0 and interface 1 were on the libusbK driver (interface 0 is supposed to have a generic driver and show up as n HID Keyboard device).

 - GUI seems to record remote buttons, but did not respond to the remote after programming.


Jason installed a new GUI, and that resolved the strange interface 0 driver issue.


The unresponsive flirc symptom was solved by changing remotes (technically, I just changed the remote that my universal remote was emulating). It turns out that the flirc is designed to respond to the most common IR frequency range of about 38khz, but a few remotes operate in a 56khz range. I had my universal remote emulating an RCA device, and RCA evidently runs their remotes at 56khz. Switched the universal remote's settings, and now the flirc respond perfectly.


I'm up and running now!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...