Jump to content
Flirc Forums

Key press delay since upgrade to firmware v3.0/software 1.2.7


Recommended Posts



I'm running Windows 8.1, XBMC Gotham 13.2. I have been using using my Flirc with a One-For-All Simple 3 remote (URC 6430) on Gotham quite successfully for about 3-4 months. When I first got it, I did have some problems with key delay, but after messing around with the 'Inter-key delay' advanced settings and flashing the firmware a few times, it started to work really well.


Yesterday I bought a Harmony Touch remote. I took the opportunity to upgrade the Flirc software (as I had seen some threads mentioning about the Harmony profiles) to software 1.2.7 and then upgraded the firmware to V3.0. Unfortunately I then noticed that the key delay was back to how it was when I first got Flirc; between half and one second delay after clicking a button before it takes affect. Most noticeable on the EPG screen on XBMC


I have tried the following:


1) Setting the 'Inter-key delay' in advanced settings to every available option (0-6) and flashing the firmware each time (I wasn't sure if the flashing was necessary, i tried it without though to no avail). I had to use a seperate Windows 7 PC that I have to re-flash the firmware as on my Windows 8.1 PC after the upgrade to software 1.2.7 the program crashes each time I run the force firmware upgrade.

2) Changing the device type on the harmony remote (thats to control XBMC) to a number of different things (Flirc XBMC, Microsoft MCE Keyboard, Microsoft Media Centre SE, a panasonic tv)

3) Changing the device delay settings in the harmony settings (interkey delay = 0 milliseconds, input delay = 0 milliseconds)


All of the above has taken me around 2-3 hours of messing about and still no difference. Then, to see if my new Harmony remote was the cause I wiped the Flirc configuration and programmed my original One-For-All (URC 6430) remote on it. The remote itself was still programmed exactly the same, but yet I now had the same key delay on the One-For-All remote. So the conclusion I've reached is that something in the v.3.0 firmware or 1.2.7 software has caused it.


Can anyone help please? I've had to go back to using a wireless keyboard as it's too slow to use.



Link to comment
Share on other sites

  • 2 weeks later...

I was going mad until I found this post... :)


But now i know I am not mad.


I have been using a Flirc for a year or so without any problem. I got some new equipment and reprogrammed my Harmony One and updated to Flirv 3.0. 

Most works fine except that the Harmony One can no longer control my Raspberry Pi based OpenElec (XBMC) installation.


How can I downgrade the firmware in the Flirc?


Edit: It seems to work for some key presses, but extreeeemly slow... I would like to try reverting to an older firmware but I don't understand how.

Edited by dboy
Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...