Jump to content
Flirc Forums

Flirc stopped working (XBMC + Ouya)


Recommended Posts



I have been using Flirc for last half a year and I love it - great piece of tech. I am using it control XBMC with the Harmony remote, XBMC being installed on Ouya. Few weeks ago Flirc unfortunately stopped working. Harmony profile is setup as it was, no other changes were made, I can control everything, just not my XBMC. I upgraded firmware to 3.0b9, Windows software to 1.2.7, no changes. Windows recognizes Flirc, I can upgrade firmware, but after instering into the Ouya remote is not working. 


Any ideas what might have happened and how should I fix it? Appreciate any help :)

Link to comment
Share on other sites

OK, I will add another piece of information. Two times already Flirc came back to life, started working flawlessly then stopped again. No changes to configuration in between, no restarting of components (Ouya, harmony hub etc.). Same problems apply when plugging into PC, one time it is recognized the other it is not...

Link to comment
Share on other sites

  • 1 month later...

I am having the same problem among others.  Originally bought Flirc about 1 year or more ago.  Used for raspbmc, worked fine (firmware 0.96?).  Didn't have time to work further on this project until a few weeks ago.  Updated Flirc to 3.0 firmware and new GUI.  Now flirc stops working after a while - totally dead, no signals recognized.


Unable to locate where on this site can open a trouble ticket.


Configuration Details:


Raspberry Pi model B, 1+amp power supply.  1+amp USB powered hub connected to Flirc and Logitech wireless USB keyboard (problem also without attaching keyboard).  Analog audio + video output.  Wired ethernet.


Raspbmc build info:

XBMC Version Info:
15:08:22 T:3037765632  NOTICE: Starting XBMC (14.0-ALPHA1 Git:20140428-6046397). Platform: ARM Linux 32-bit
15:08:22 T:3037765632  NOTICE: Using Release XBMC x32 build, compiled Apr 28 2014 by GCC 4.7.1 for ARM Linux 32-bit 3.2.21

Kernel Version:
Linux raspbmc 3.12.21 #2 PREEMPT Wed Jun 11 04:53:06 UTC 2014 armv6l GNU/Linux

Flirc Firmware: v3.0
Flirc GUI Version: v1.27
  Git Version: v1.27+
  Based on Qt 4.8.0

Windows Version 8.1 (for GUI)


Remote Device:  Sharper Image 7-in Universal remote, using SBT button programmed for LG Home Theater code 0898.

Link to comment
Share on other sites

I'm sorry to say that you can add me to this list.

I too have a Flirc / OUYA / Harmony remote configuration.


For a while the Flirc kept dying on me and I would plug it into my Mac with the GUI - it would say 'bootloader detected' and then put the firmware on it. I would restore my settings and it would work again for another week or so.


But now, although the GUI will report that the Flirc has Firmware 3.1 on it, I am unable to get the Flirc to receive any signals.

When I try to make any changes in the advanced menu or force a firmware upgrade, the GUI either hangs with the 'Please wait firmware upgrading' message or it says 'Firmware upgrade failed. Contact support.'


I sent a message to Support with the 'Contact us' page on the site.

I hope someone gets back to us about this! 

Link to comment
Share on other sites

I've tried firmware version 3.1 and 3.0, and I'm having similar problems.


In my case, I'm able to record keys, but the keymap in the Flirc GUI does not light up once the buttons are recorded, and the buttons do not function in windows 7 or on my OUYA.


Yes, I have tried force upgrading firmware, and turning off sleep detection.

Link to comment
Share on other sites

Well, after 2 days with v3.1 firmware (sleep detection still on) everything works so far ok. I have cleared configuration on flirc, synced once again Logitech Harmony hub and did full restart on OUYA just to be sure. We will see in few days but there is an improvement already in my case

Link to comment
Share on other sites

  • 1 month later...

I also have the Flirc/harmony/ouya and this exact problem has happened to me.....all the sudden the flirc has become unresponsive. I had been using the flirc just fine for the past while on firmware 2.4 and only recently upgraded to the latest (3.3) to see if I figure out how to wake my ouya from sleep.

Big mistake. I wish I had of just left it alone. My pc is able to recognize the flirc ...I'm able to record buttons through the GUI but it refuses to command them upon press. I've tried the flirc using different remotes on my ps3, pc, and my ouya each time producing with the same result...unresponsive. I left it for about an hour and suddenly it worked for bout 5 minute then shit the bed again.

Is there a way to downgrade my firmware back to v2.4.?

Edited by bigpen15crew
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...