Jump to content
Flirc Forums

flirc USB 3.0 + Linux?


Recommended Posts



I recently purchased a new computer and it seems in linux that my Microsoft infrared receiver (philips model) no longer works on this new machine.  I am using ubuntu, I tried 12.04 and 14.04 with no luck, in usb 2.0 and 3.0 ports.  The device is recognized but does not work.


It works fine in windows so it leads me to believe this is a linux hardware issue.  It works fine in linux on an older machine that has 1.1 usb ports.


So the question is will this receiver work in ubuntu 14.04 with the newer machines that do not have 1.1 usb hubs on them?


I have a Gigabyte GA-B85M-D3H mATX motherboard

Link to comment
Share on other sites

Have you tried other USB devices on this new computer under Linux? Maybe the problem is with the motherboard hardware and not with the receiver itself.


Flirc works by emulating USB HID keyboard so it SHOULD work as long as a normal USB keyboard also works.

Link to comment
Share on other sites

Hi, I installed windows and everything works just fine (including the receiver).


Under linux all other usb devices work (keyboard, mouse, external hard drives etc).  It seems only the IR receiver has an issue.


From what I can tell this seems to be a chipset driver issue of some sort.  Odd it works in windows with no drivers though.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...