Jump to content
Flirc Forums

Flirc not connecting/working after restart

Recommended Posts



Firstly, I am very impressed with flirc when I first programmed it, everything on my Win 7 PC for XBMC worked fine.


However, after booth reboots and turning the computer on and off, apon restart my remote does not work. I noticed in the devices and printer section in the control panel that flirc is not listed after a restart as a USB keyboard; instead bootloader is listed.


The only way I can fix this is to open the flirc gui used to assinged buttons and then it says 'bootloader found', it connects (slowly) as DFU, and then I can use it.


This seems a bit inconvenient - I assumed (like with my bluetoth keyboard) that after restart it would just 'be there'.


I did have problems initially installing the drivers. So FYI what I did was installed the flirc driver first then a device called btld i think it was requested the bootloader drive.


Anyway, I hope this is a simple solution for this as, apart from this minor inconvenience, flirc is amazing!


I look forwrd to hearing any ideas from anyone on what I can try tyo get flirc to connect automatically as a USB keyboard without loading the gui



Link to comment
Share on other sites

That's definitely not working as expected, it shouldn't be doing that.


Have you tried going into the file menu on the flirc GUI and clicking "upgrade firmware"?


If this doesn't help we'll get you in contact with Jason and he'll sort you out :)

Link to comment
Share on other sites

Hi Chris


Thanks for the reply. I clicked on 'upgrade firmware' which of course took me to a file browser for the firmware file, but I do not know where the firmware file is. I am current on 2.6. Where can I find the latest or alternative firmware to update it with?




Edited by megatron_lives
Link to comment
Share on other sites

I did force firmware update to the same, latest firmware, but this did not solve the problem. Are there any services which flirc depends upon, or that start when the gui starts? Only I have some services disabled/manual which may be something for me to look at.....


If not, what else can you recommend I try?

Link to comment
Share on other sites

  • 3 weeks later...

Did you get a reply to this?


I have several that are doing the same and am looking for a fix for this.

I connected it to a PC and opened FLIRC and it detect bootloader and then the small loading bar appeared (and loaded) for 5 seconds.

I plug it back into the media player and it works again with the previously programmed config.


They are running version 2.4, but force FW update says 2.4 is the only one available.




Link to comment
Share on other sites

Hi Henning


Yes did get a reply. Jason contacted me directly and we got the problem sorted. I would recommend if you are experiencing this problem to email flirc support and hopefully this can be resolved fro you.


To Jason - Thank you so much, I love the Flirc, it is working perfectly with my HTPC!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...