Jump to content
Flirc Forums

Linux And Windows Differences


Recommended Posts

March 12, 2014




First thing to say would be that I am no Linux expert, I just get by. But finally got the Flirc GUI installed and working in a Debian Wheezy system.  First attempt was done by modifying the /etc/apt/sources.list and running the apt-get.  That only resulted in the error:

Err http://apt.flirc.tv binary/ Packages 404 Not Found

Which means to me that the website is the problem.

To have an idea when this going to be fixed would be extremely good since I would stop wasting time trying to figure out what is going on. Maybe on the download page - put a notice.


The second method used to install the GUI program was to download the program itself. After creating a file "flirc.rules" in the directory "/etc/udev/rules.d", I finally got the GUI program to connect with the Flirc module. The flirc.rules file only contained one line:

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", MODE="0666", GROUP="UserName"

where UserName in GROUP="UserName" is the login of the user.

I still don't know if this is correct or not and if there are any repercussions but it works.


I also did an install in a Windows XP and a Windows Vista that are both running in VirtualBox from Oracle right in my Linux desktop. In both Windows everything seems to work.


My questions are:

- Why in Windows I have a top menu that has the items "File, Controllers, Help" and these are not apearing in my Linux GUI.

- Where are the firmware files? I just can't find them nowhere. Both the Windows and Linux versions of the software report:

Software version: 1.2.2

Firmware version: 1.2


I would really like to be able to use this Flirc device because I think it was and is and will be an excellent idea/design. It's just that after 3 days of trying to get this working properly in Linux, I seem to get into trouble at every turn I make and there is no indications on the website about any website problems.


Many thanks






Link to comment
Share on other sites

Thank you for responding MrNice, I appreciate it.


But the link you mentionned above is where I got the Linux version of the software.  And it does work but you can only test/program what is called a "Minimalist" which is the remote control's arrow keys, Enter key and Back key.  In Windows you can program all keyboard keys.  It's just I wonder if I made a mistake in the installation or that the Linux version really only does the "Minimalist".  To me it just seems improbable.


Also I can find a lot of posting about the firmware but none of the links I tried worked.

Link to comment
Share on other sites

Just wondering which OS version you downloaded.

Proposed versions are for the OS you run the GUI.

In my case I have a 64 bits Mint/Mate OS and I use Latest Version [Linux 64] => Flirc-v1.2.2-x64 directory when extracted

Menu has: File, Controllers, Help

Controllers has: Minimalist, Full keyboard, Boxee, XBMC, Windows Media, Media keys.

It's run well right now with the CLI:

$ sudo ./Flirc


Link to comment
Share on other sites

I had downloaded the right files for the right platform.   But thanks to the last line of your last post ("$ sudo ./Flirc"), I realized that my user was not part of the "sudoers".  So although the Flirc GUI program would start and say that the Flirc module was connected, there was no menu available.  I remedied the problem with the following (in case someone else encounters the problem).


Open the sudoers list by opening a root terminal window and using the visudo program to edit the list like so:

# visudo


Find the line that has "root ALL=(ALL:ALL) ALL" and copy it right below itself changing the word root to your username so it looks like below:

# User privilege specification


username ALL=(ALL:ALL) ALL


Now save your changes and restart the Flirc GUI program in a user terminal window with the command below. My desktop is KDE so I use "kdesudo". You might need to use "sudo" or "gksudo" for Gnome desktop, it depends on your system.

$ kdesudo -u username ./Flic

Once the program is started, click File -> Advanced -> then click the button "Force FW Upgrade". After a minute or so, "Firmware v2.3" will be displayed on the bottom left hand corner of the window.


MrNice, I wish you a good life, you certainly made mine better today.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...