Jump to content
Flirc Forums
stony

[Solved] How to reassign the back button

Recommended Posts

Hi there,

 

I've setup up flirc with my Samsung tv remote and it works very well. The "back" function has been assignet with the back button in Flirc's XMBC settings, see here:

post-4380-0-08050600-1364559233_thumb.jp
 
Well I would like to disable it in fullscreen video mode and tried some settings in my keyboard.xml file (located at \pi\.xbmc\userdata\keymaps).
 
Here is the file:

<keymap>

 <FullscreenVideo>

      <remote>
          <back>Info</info>
      </remote>
      <keyboard>
          <back>Info</info>
      </keyboard>
  </FullscreenVideo>
</keymap>

 

But instead of the info screen, the back action triggers. I don't know how the back function (see screenshow above) is named. Can anyone help me?

post-4380-0-08050600-1364559233_thumb.jp

  • Like 1

Share this post


Link to post
Share on other sites

Hi stony,

 

your setting is incorrect, it should be something like... although I am not 100% sure abut "back" part 

 

<keymap> 
  <fullscreenvideo>
	<keyboard>
	  <back>info</back>
	</keyboard>
  </fullscreenvideo>
</keymap>

Check post in my sig you will find lot of info abut customizing keyboard + keymapedit which is developed by xbmc team to easily edit keyboard settings.

 

hope this helps...

 

btw. no need to ad remote section as system sees flirc as standard usb keyboard 

  • Like 1

Share this post


Link to post
Share on other sites

As usual some top notch help from Burke :)

 

He is also correct to doubt the "Back" part:

<back>info</back>

 

What you'll notice about the keyboard.xml (which is what you'll be using for Flirc as it appears as a keyboard) is that the brackets "<" and ">" contain keyboard buttons. Back isn't a keyboard button but an XBMC function.

 

I imagine the XBMC profile (intended to make programming easier) has caused some confusion as a lot of users don't do the advanced settings you are :).

 

The XBMC preset matched up the appropriate keyboard button to the function in XBMC. So when you programmed back in the flirc GUI it sends backspace. So the line for the keyboard.xml you want is:

<keymap> 

  <fullscreenvideo>
    <keyboard>
      <backspace>info</backspace>
    </keyboard>
  </fullscreenvideo>
</keymap>
 
So what this line of code is saying: When in fullscreen video, when backspace is pressed display info.
 
Does this help?
 
+1 for Burke's thread on customisation in XBMC too (see his signature). Should you want to experiment further.
  • Like 1

Share this post


Link to post
Share on other sites

Hey guys,

 

thanks for your help. Actually <escape>Info</escape> did the trick, don't know <backspace>info</backspace> doesn't work.

 

Now I'd like to disable the button in fullscreen video mode. If I only put <escape></escape> in the xml file the default actions is triggered. How can I disable the button just in fullscreen video mode?

Share this post


Link to post
Share on other sites

Apparently it's "noop". I just had to look it up here:http://wiki.xbmc.org/index.php?title=Keymap

so it would be:

<escape>noop</escape>

 

 don't know <backspace>info</backspace> doesn't work

Oh yeah, I forgot. The back and exit button in the XBMC preset in Flirc are mapped to the same button (exit). If you want separate back and exit functions on your remote - use the full keyboard. Sorry!

 

Hope you're enjoying your Flirc otherwise :)

Share this post


Link to post
Share on other sites

Thanks Chris, works like a charm.

 

And yes. I can definitively say yes! I never thought that I can control my Raspberry Pi with the tv's remote, but Flirc made it possible. I really love this tiny infrared receiver :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×