Jump to content
Flirc Forums
Monti

FLIRC driver installation keeps failing

Recommended Posts

I just got my FLIRC, unpacked it, plugged it in, got the usual keyboard screen, closed that, then tried installing the latest driver from the website. But no matter what I try, the program just won't open and keeps crashing. I thought it might be a compatibility issue, since I'm on a Mac and my current OS is High Sierra. So I tried it on a different Mac that has El Capitan, but the same thing happens: the app icon bounces and then immediately closes again. The crash report says that a certain library couldn't be loaded, so I recreated the path from the report and copied the framework file in question over. That only ended up giving me another crash related to a different library, so I copied that framework file over as well, only to get the same thing happening again with another library. I kept doing this until I got a crash report without any obvious suspects. 

The files in question were the following:

  • QtCore.framework
  • QtGui.framework
  • QtNetwork.framework
  • QtGui.framework
  • QtSvg.framework
  • QtWidgets.framwork

And here is an excerpt from one of the crash reports (it's the same on both my devices):

"Termination Reason:    DYLD, [0x1] Library missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: /usr/local/Cellar/qt@5.7/5.7.1/lib/QtCore.framework/Versions/5/QtCore
  Referenced from: /Applications/Flirc.app/Contents/Frameworks/QtGui.framework/Versions/5/QtGui
  Reason: image not found"

Seeing how I get the exact same issue on two individual devices, one of which is a two day old MacBook with a clean install, I think it might be an issue with the current version of the driver. I would really appreciate if someone could provide me with a version of the driver that works for them on their Apple computer, so I can troubleshoot that way. If that doesn't work either, I really have no idea what could be causing this. 

Would appreciate any help on this.

Edited by Monti

Share this post


Link to post
Share on other sites

I'm using a service called travis to do building and releasing for me. Kinda new and it looks like I had an issue with the last release. I posted a new version this afternoon, should fix it. You'll need to grab the latest from the downloads section on the website. Very sorry for the inconvenience. Please let me know if all is well, we're on version 3.5.2 now.

  • Like 1

Share this post


Link to post
Share on other sites

I ended up finding an older version of Flirc and installed that without trouble. Tried 3.5.2 on my other device again though and that installed fine this time, so the issue seems to be gone.

Thank you for the quick reply! I'm very happy to be able to use my Apple Remote even with my newer MacBook again.

Share this post


Link to post
Share on other sites
Just now, Monti said:

I ended up finding an older version of Flirc and installed that without trouble. Tried 3.5.2 on my other device again though and that installed fine this time, so the issue seems to be gone.

Thank you for the quick reply! I'm very happy to be able to use my Apple Remote even with my newer MacBook again.

Great, so glad it's working, very sorry for the initial inconvenience.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×