Jump to content
Flirc Forums
Rumik

XMBC, Harmony 700, shutdowns xbmc instead of the pc

Recommended Posts

Hi everyone,

Got my flirc today and everything is setup fine and working, except for shutting down the xbmc pc. I have the flirc setup as a windows media centre device in the harmony config page and when using the All Off button, or the shutdown button I assigned, xbmc closes rather than shutting the pc down.

Any ideas?

Thanks

Share this post


Link to post
Share on other sites

Hi Rumik, welcome to the forums,

I'm not sure about windows (unfortunately I don't use it), I sounds like the shutdown button sends alt+f4 is this right?

What did you program the off button on your remote to on your Flirc?

pleasant regards,

Chris!

Share this post


Link to post
Share on other sites

I chose the shutdown xbmc option in the flirc setup, which I guess makes total sense why it's closing it instead of suspending, lol! I've tried setting up a shortcut to sleep the machine but for some reason the keyboard shortcut I've set it up to use won't work, so I can't even program flirc to use it. I've also not been able to figure out a way of getting my remote to use the "All Off" button to suspend my XBMC pc... not sure if that's possible?

Share this post


Link to post
Share on other sites

it should be possible, I seem to recall the user mentioning it elsewere on the forums.

I'll have a dig around on the forums when I'm not on my phone and get back to this thread (or if someone else wants to share their probably more knowledgable experience please do)

Chris!

Share this post


Link to post
Share on other sites

I've got the sleep shortcut working now, so I've assigned it to the red button on the remote, but the machine won't wake with the same button. I know my machine can do it, as I've been doing it with my mce remote before now :(

Share this post


Link to post
Share on other sites

The continued discussion on the OP's wake issue can be found in this thread:

I thought about closing this thread at the OP's suggestion, but thought it might be worth discussing a quick XBMC tip: If you go to Settings -> System -> Power Saving and make the chosen Shutdown function is Suspend, choosing shutdown from the menu system should suspend the box. Then the ShutDown function can be defined in Keyboard.xml and assigned to any key that flirc has mapped. Or, if the skin you're using has Shutdown as an option in the menu that comes up when you press S, just map a remote button to the S key in flirc, and when you press it you can select Shutdown from the menu and your system will suspend. The default Confluence theme has a Suspend option in the S menu, so you don't even have to define the Shutdown function to get it in there. Here are some relevant links:

http://wiki.xbmc.org/index.php?title=List_of_built-in_functions

http://wiki.xbmc.org/index.php?title=Keymap.xml

http://wiki.xbmc.org/index.php?title=Shutdown_Menu

  • Like 1

Share this post


Link to post
Share on other sites

Shutting down/suspending isn't the problem now, it's waking up again afterwards :)

Yes, that's why I was going to close the thread. I just thought someone else might stumble upon this thread looking for an answer to your original question and wanted to share some info in case it might be helpful to others. I'll close the thread now.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×