Jump to content
Flirc Forums
matanlir

flirc causing random scrolling and clicking

Recommended Posts

hi,

 

I have flirc for more than a year now (using version 0.96 at win7) connects to my TV IR remote without any problems. lately, about a month ago, I had random scrolling and clicking which at first I though has to be a keyboard/mice bug. after multiple checks I discovered the problem caused by flirc. I upgraded flirc to the latest version and the problem continues.   

 

THANKS!

Share this post


Link to post
Share on other sites

Sounds like you are getting IR signals from a random source, maybe a lightbulb?

 

Try making the room as dark as possible, turn off all lights, close the blinds, and see if the problem persists.

Share this post


Link to post
Share on other sites

You're using XBMC Gotham beta or RC1?

Then this isn't an issue caused by the flirc device!

It's a bug within xbmc itself. I'm looking for a solution, but didn't found something yet.

Share this post


Link to post
Share on other sites

Guys - I'm experiencing the same. I'm using an Xtreamer IR remote to a ASUSTOR NAS and play on its XBMC. I've replaced my USB extension cable and tried the front USB port of the NAS (where there's no extension cable) but random key presses still happening. After a few tries I've found that the flirc receiver appears to be sensitive to the T2 fluorescent tubes I've installed for my living room. I switched the fluorescent off and the random keypress is gone. If I switch on the fluorescent again then the random keys press starts again. The fluorescent tubes are not directly shining to the remote it hits the walls/ceiling and reflect the lights. When the problem happens it's likely to be continuously hitting the top/right direction buttons.

 

My config:

Sleep Detection off

Noise Canceller on

Built-in Profile off

Interkey delay 3

Edited by sywong2000

Share this post


Link to post
Share on other sites

Guys - I'm experiencing the same. I'm using an Xtreamer IR remote to a ASUSTOR NAS and play on its XBMC. I've replaced my USB extension cable and tried the front USB port of the NAS (where there's no extension cable) but random key presses still happening. After a few tries I've found that the flirc receiver appears to be sensitive to the T2 fluorescent tubes I've installed for my living room. I switched the fluorescent off and the random keypress is gone. If I switch on the fluorescent again then the random keys press starts again. The fluorescent tubes are not directly shining to the remote it hits the walls/ceiling and reflect the lights. When the problem happens it's likely to be continuously hitting the top/right direction buttons.

 

My config:

Sleep Detection off

Noise Canceller on

Built-in Profile off

Interkey delay 3

 

See this thread: http://forum.flirc.tv/index.php?/topic/1205-really-freaking-frustrated-with-my-flirc-but-its-not-your-fault/?hl=sunglasses#entry7392

 

Please cary the conversation on there. Note my last message at the bottom, I think I have a fix but would need to carry this conversation out privately, not ready to make this public.

Share this post


Link to post
Share on other sites

I am having the same issues. I've been using my device for about 8 months now and its gotten worse in the past month.  I'm running on Windows 7 and notice random scrolling and clicking.  I've stopped using my device because it's so annoying.  I'm running the latest version (downloaded yesterday) and still have the issues. 

Share this post


Link to post
Share on other sites

I'm going to post a beta image for everyone to try to help solve this. I'll make an announcement shortly.

Share this post


Link to post
Share on other sites

okay, made some great progress. I'll need a few more days to clean this up before the release. Thanks for the patience guys.

Share this post


Link to post
Share on other sites

FYI, I have been able to duplicate this same error on XBMC 13.1 Gotham, running on Windows 7 Pro 32 or 64 Bit, on USB 2.0 or 3.0 ports, with Visio Remote XRT-110. on all 3 of my XBMC machines.

Looking forward to testing the new version you are working on.

Share this post


Link to post
Share on other sites

Okay. Starting to take form. I've rewritten my firmware and I have a new adaptive algorithm that's going to help with noise suppression and all rc6 remotes will now work. I have two more items that need attention for the fw, and then I'll start working on putting together beta packages.

  • Like 1

Share this post


Link to post
Share on other sites

Okay guys, 2:30 AM here, I'm sorry, couldn't finish it tonight. I'm close.

Just a heads up this will be beta, and there will be a few features missing. I completely re-wrote nearly all the firmware. It's going to go up tomorrow...err. today... after sleep.

Share this post


Link to post
Share on other sites

Check the beta thread I have the third version of the release candidate up. Please please let me know if it helps solve this.

Share this post


Link to post
Share on other sites

Unfortunately i'm facing the same issue. Phantom Keys while scrolling in XBMC. I tried the latest RC4 Release, installed MediaPortal to see if it's aXBMC issue (it's not, same issue on MediaPortal), tried to place Flirc behind a dimmed glas, tried several remote controls, modified any setting in the GUI. No success at all.

In the meantime i upgraded from Win 7 x64 to Win 8 for troubleshooting, but still no success.

 

Any helpfull hint ?

Share this post


Link to post
Share on other sites

Unfortunately i'm facing the same issue. Phantom Keys while scrolling in XBMC. I tried the latest RC4 Release, installed MediaPortal to see if it's aXBMC issue (it's not, same issue on MediaPortal), tried to place Flirc behind a dimmed glas, tried several remote controls, modified any setting in the GUI. No success at all.

In the meantime i upgraded from Win 7 x64 to Win 8 for troubleshooting, but still no success.

 

Any helpfull hint ?

Yes, please make sure you're on the 3.0 firmware version, and you clear your configuration and start over. After that, please let me know.

Share this post


Link to post
Share on other sites

hi jason, I've had the latest update and firmware 3.0 and it seems that the issue SOLVED, thanks!.

I also noticed that the responsiveness is not as smooth, some keys enforce long click or few clicks to work, I've tried to clear the configuration
and change the inter-key delay and it yet the same. the recorded keys doesn't stay locked - the massage 'button already exists' doesn't always appear and it just records again.

Share this post


Link to post
Share on other sites

keep the interkey delay at 3. What remote control are you using, I'll take a look. i do have some improvements I will push soon.

Share this post


Link to post
Share on other sites

How do you download Firmware 3.0 - when I go to download via advanced settings I get upgrade to latest 2.6 and I am already on 2.6 - I have the issue of random clicking and scrolling in both windows and openelec and the flirc device is useless unless I can update the firmware as this has fixed others with the same issue - flirc version is 1.26 - I have seen mention of 1.27 but again can find nowhere to download this.

 

Help please.

 

thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...