Jump to content
Flirc Forums

bgmCoder

Members
  • Content count

    14
  • Joined

  • Last visited

Community Reputation

0 Neutral

About bgmCoder

  • Rank
    Junior Flirc-er
  1. Thanks! It finally resolved itself and is working on all the ports now. I love these things!
  2. So I tried a third USB port and Flirc works on the third port. It's just borked on the first two USB ports. I'd like to fix that!
  3. A long time ago I wrote to you for help, and Mr. Chris and Mr. Jason were very kind to me. I have Windows 7 x64 Well, I have these two Flircs (you all sent me one of them for free back when I had troubles the first time) and they are a bit old; I think from 2015. I have installed the latest Flirc GUI and upgraded the firmware on my Flircs from 3.6 to 3.9. You can see that Flirc has the 3.9 driver. Neither of my Flircs respond to the remote control's commands. I can program the buttons just fine in the GUI But I'm getting this in the device log. In the Windows 7 Device Manager I see under Portable Devices the WPD FileSystem Volume Driver is in a warning state with "This device cannot start. (Code 10)". I tried uninstalling these drivers and re-inserting the Flirc, but it comes back to the same situation. I also see the Flirc Driver there under libusbK USB Devices; I tried uninstalling this too and deleting the device drivers. Is there something I can do?
  4. Well, I'm starting to lose hope! I sent in my support request and have received no reply. My Flirc is borked and now my hopes are borking. I think I would like to try a different driver. Some of the forum threads talk about using a different driver, but I can't find any way of getting an older version. Too bad there's not a list of old drivers than we can download. It's the only thing I haven't tried - because I can't!
  5. Hi, Chris. I sent an email via the page just this morning, in fact. I've even used Geek Uninstaller to remove Flirc and its regristy entries (which are not removed by the installer, by the way). Then I used Nirsoft USB De View to uninstall the usb entries. And reinstalled. But it's still borked! I bet you all must be pretty busy with all this. I've force-upgraded the firmware via the gui. I've used Zadig to resintall the libusbk driver for flirc interface0 and flirc interface1. The computer knows when I plug it in, Flirc GUI knows when its connected, and I can record keys now, but it can't play them back in the GUI, and the remote doesn't work (although it did at first just fine). And it's still borked. So, I'm looking forward to hearing from Jason!
  6. My Flirc is borked. I'm going to go cry in a corner now.
  7. Allright, this is not going so well. So I tried the zadig method from here. It seems the winusb driver is always being installed instead of libuibk. And I don't see bootldr in the list of devices. And flirc doesn't work in either usb port now. I've uninstalled and reinstalled flirc to no avail.
  8. I plugged it into a different USB port that it had never used before and it started working. This reinstalled the driver for that port. Somehow the driver must have borked on the first drive. So I thought I'd try it in the other drive again, it didn't work there, and when I put it back in the second one, it stopped working there too. So it seems to be a driver problem. Windows 7 x64. When I look at it in Nirsofts USB DeView, it is like this: 0000.001a.0000.001.005.000.000.000.000 flirc Vendor Specific Yes Yes No No 6/2/2015 3:23:05 PM 6/2/2015 3:23:06 PM 20a0 0001 1.00 ff ff ff libusbK libusbK USB Driver 12/25/2013 - 3.0.6.0 libusbK.sys libusbk devices Flirc Inc 100 mA 1.10 flirc 3.0.6.0 USB\VID_20A0&PID_0001&MI_01\7&2f3fd6ab&1&0001 So I uninstalled all the flirc entries and when I plug it back in it reinstalls and then works. But if I unplug it and plug it back in, it does not work. Seems like I have to reinstall the driver to get it working again.
  9. Well, it's recording the mod keys now, but it thinks that 1 is ! It's as if the buttons I push on the gui keyboard are not registering correctly. The gui says its pairing with lwindows+1 but flirc_util.exe keys says that is +left_cmd+! strange! [later] okay, now it lets me record, but it never sends anymore. sigh. C:\Program Files (x86)\Flirc>flirc_util.exe keys Recorded Keys: Index hash key ----- --------- --- 0 6C7ADFBB +left_cmd [ 1 473E5042 +left_cmd ] 2 A4DBB3ED space 3 7F9F2474 f 4 F9167BBB +left_alt 0 5 1E530B34 +left_alt 0 6 686077A6 S
  10. okay, I think I fixed it. I exited the gui and unplugged the flirc. then plugged flirc back in and started the gui I can record normally now.
  11. Never mind - I used the commandline: flirc_util.exe dfu and that fixed it. It erased all my pairings, but it will record again. I think what had happened is that I used the flirc gui's "Force FW Upgrade" to see the firmware version, but cancelled out. It put the upgrade status into "error" and after that it was broken. So it seems like cancelling out of the "Force FW Upgrade" window has a teeny bug somewhere. Finishing the upgrade fixed the issue. [later] Uh, no it's still broke. it worked for a moment, though. So I used "clear configuration" but that doesn't fix it.
  12. I'm not sure what happened - it *was* working... but in the FLIRC GUI, when I enter keyboard mode, when I click on win, alt, or ctrl keys (mod keys) they are not being recognized. I mean that the keys don't turn green like they are supposed to. other, non-mod keys work fine. How do I fix this? I've tried stopping and starting the gui.
  13. How to know which buttons are paired?

    Thank you! That's what I wanted! I did a quick search and didn't come up with that - so thanks for the link!
  14. Today I installed flirc and am able now to adjust my system volume (windows 7) using an old Sony Radio Cassette remote control. Neat! However, my question is this: How can I know which buttons are already paired and what keys they send? Is there a way to get such a list? The flirc gui doesn't give you much information about your configuration.
×