Jump to content
Flirc Forums

Several problems with GUI 1.2.2


Recommended Posts



I have a few problems with my FLIRC, using the GUI 1.2.2 on Win 7 x86_64:

  • Whenever I start the GUI, I see "Disconnected" in the status.
  • If I unplug and replug the FLIRC in a USB port that was not used in the past for it, the driver installs and it get recognized by the GUI.
  • When recognized, I can (could, since I used all my USB ports in the meantime...) define key mapping using the GUI.
  • I tried to update the firmware using the "Advanced>Force FW Update" menu, but this caused the GUI to hang each time (after it discovered a new version and I clicked to proceed).
  • Even if the GUI does not recognize the FLIRC, it appears in the Device manager
  • Zadig indicates the correct driver for FLIRC (interface 1): libusbK v3.0.6.0
  • The GUI indicates firmware v-16.-16 when I manage to get it to work.

I already tried several installations of the GUI (including older versions) as well as uninstalling the device in Device Manager but to no avail.

Any clue on how I could upgrade the FW and get the GUI to work in a more predictable way?

Thanks in advance for your help. I can do some more research/debug if needed.



Link to comment
Share on other sites


Seems both my flircs are bricked after upgrading the GUI to 1.2.2 and firmware to 2.3. That's what I get for doing them both at the same time hoping it would fix the ghost presses on both machines..

No longer work at all on my raspberry pi running xbian.

On Win7x64 it keeps installing the wrong driver. I keep fixing with zadig.

Sometimes see the firmware -16 -16.

Immediately disconnects from GUI and disappears from device manager if I press a button on the remote.

I managed get one flirc back to firmware 2.0 with GUI 1.0.6 but same problems. Still won't work on raspberry pi any more (that's the firmware version I was running previously). 


EDIT: OK they're not bricked. Installed software on another Win7x64 machine. Updated firmware, cleared and reloaded config. Both flircs working on that machine. Used system restore on original win7x64 machine. Uninstalled and reinstalled software. Both flircs working on this machine (my htpc).


Neither flirc works on my raspberry pi running xbian. The flirc is the only input device I've used on the raspberry for the past 4 months and now I have no way to use it without getting this fixed or buying a different input device. I'll try putting a fresh image on the SD card in case the driver is hosed. If that don't work I guess I'll need to try to revert back to firmware 2.0. (via fw_1.0.bin)


EDIT2: Decided to try again before wiping the SD card. Today flirc works again on my raspberry pi without changing a thing,

Link to comment
Share on other sites

  • 2 weeks later...

The issue is the GUI, 1.2.2 is no good at all.


I had the same symptoms.


Now here is what I did:

1. used flirc_util.exe reboot

 flirc_util.exe format

 flirc_util.exe keys - showed no keys

 flirc_util.exe load_config (I saved it before)

Now  flirc_util.exe keys - did show keys, but flirc did not accept my harmony remote

did another  flirc_util.exe format

and now all my keys are back


If at ANY time, I start the GUI, every keypress, disconnects the flirc 


The GUI is no good, cannot record,delete anything from it.


I installed the driver as explained, still GUI is the issue

I am using Windows 7 64 bit



Hope you fix this issue soon (I have 3 flirc devices)


Tried on zotac running openelec, rpi. windows 7 - GUI IS NOT GOOD

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...