Jump to content
Flirc Forums

Flirc V2 Libreelec remote gets stuck in some menus


Recommended Posts

Received Flirc V2 today. Both software on MacOS and firmware are current as of Mar 12, 2022. The subject remote is XRT136 for Vizio TVs.

The problem is that the remote gets stuck in some menus, then I use a usb keyboard to unstuck it, after which the remote works fine. The behavior is repeatable in the same menus.

With the GUI, using the full keyboard template, I recorded remote keys successfully. Moved to my Libreelec box running Kodi 8.2.5. Remote appears to work successfully. As I pushed the Flirc-remote by navigating every corner of the system, I ran into several menus where the remote gets stuck. I also have a keyboard attached, so I hit "backspace" which takes me to previous menu. This action unstuck the remote as well, and it continues to work without any problem. Go in the same menu, it gets stuck again. One problematic menu is Libreelec settings and the other is Kodi System Audio selection menu.

With this exact same Libreelec hardware and software I used an IR remote which came with its receiver, and a 2.4Ghz wireless remote successfully without any problems for a long time.

Any suggestions?





Link to comment
Share on other sites

Some additional info.

If I browse the system too long (did for testing), then it gets very slow or stuck in other menus as well. It is as if a buffer is fulling or something.

Tried upgrading Libreelec from 8.2 to to 9.2, problem continued as before.

Played with the BIO of the Zotac mini PC Libreelec is installed, specifically tried changing all USB related entries one at a time. No effect.



Link to comment
Share on other sites

I did some more experimentation and almost conclude that Flirc has a problem with my mini PC.

What I did is, programmed my TVs remote's few unused keys to basic Kodi functions. This eliminates the possibility that the remote is the problem, because it runs the TV just fine. Programming completed successfully. Opened a text app and verified the programmed keys are captured.

Then moved Flirc to the media mini PC and used the remote. It showed the exact same symptoms as the previous remote. When it got stuck, I moved Flirc back to the main PC and verified that keys are received on the text app. Did this round a couple of times, every time the remote gets stuck, works fine on the PC, take it back and continues to be stuck until moved out with a keyboard.

Now, I will change my question to a very simple one, hoping I will get some feedback. I can exchange the Flirc with a new one. Should I do that and try a new one, is it possible that this Flirc is faulty. Or is it that the media PC is simply not compatible with this firmware of Flirc and there is nothing I can do about it?


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...