Jump to content
Flirc Forums

Rpi no longer receiving input from Flirc Gen1 after firmware upgrade


Recommended Posts

Moved this from general questions, prolly not the best place for this issue:


Dear All,


I bought a flirc usb stick back in 2015, the one of transparent plastic.

A couple of years ago, I used it to for a WD remote control that I´ve used with KODI on Rpi ever since. However, the buttons on this are becoming more and more irresponsive, so I decided to find another unused remote and configure it the way I did with the old one.

I then installed the flirc software on my wifes laptop, that´s just about 2 years old. This did not install the driver, so I found this zodaq or whatever it´s called and got them installed that way, checking that the device was showing in device manager. That didn´t make the flirc software see my stick, saying "please connect flirc", so i went up to the PC where I´ve configured flirc from before. The PC immidiately recognized the stick and installed the drivers for it, showing up as it should with no errors in device manager.

I tried with the version of flirc from a couple of years ago, that was already on the PC and then with the latest version, but still: None of them worked, here I also just got "please connect flirc".
My best bet is that this is an incompatibility issue with recent versions of windows 10, but what do you think?


EDIT: I found the post about Gen1 of flirc here on the forum, not sure why there´s not a choice of the download page for this, but so be it. Installed it, and to my great surprise I saw that it now sees my flirc.

I configured another remote, upgraded firmware as it suggested, and connected flirc to my pi again.
Just to find out that now flirc did not respond to any of the remotes anymore :(

I then put the flirc back in the laptop, and suddenly realized that it keeps on wanting to upgrade my firmware, but is stuck at v x.11,  but tries to upgrade to x.12. The one I had before was x.8, and I´m thinking that the firmware is what has now messed up things.

Anyway, put it back into my pi, and now it suddenly worked! Well, the keys weren´t all as expected on the new remote, so I put the flirc back into the laptop to reconfigure, and finally put it back into my pi again.
Guess what... again it´s not responding. 

Any hints here? Is this indeed a firmware problem, as I think, and would anybody know how to downgrade to the older firmware version and how to get that firmware file?

FYI, the  device seems to be known by the pi, which is btw a model 3B with libreelec (kodi) on it:

Bus 001 Device 126: ID 20a0:0002 Clay Logic

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...