Jump to content
Flirc Forums

What happened to my Flirc after failed upgrade?


Recommended Posts

Hi, after some time I launched the Flirc app and it asked for an upgrade. I confirmed, it upgraded, later asked to upgrade fw also (v4+ I believe, but not sure) and died. Flirc seems to be dead since, I tried to unplug it many times, reinstall the app, a few commands, nothing. Flirc 3.25.3 says Connected [DFU] and (not responding), it just freezes after launch. Device seems to be bricked:

PS C:\Program Files (x86)\Flirc> .\flirc_util.exe unit_test
Self test not supported
Flirc Fucked
Flirc Not Okay
Flirc Not Okay
PS C:\Program Files (x86)\Flirc> .\flirc_util.exe version
Bootloader Version: v3.3.0
   SKU:     Flirc 2.0 [dori]
   Hash:    0x3872A2F4
PS C:\Program Files (x86)\Flirc> .\flirc_util.exe device_log
NVMCTRL bad command
Reset Cause:
    SYST:  False
    WDT:   False
    EXT:   False
    BOD33: False
    BOD12: False
    POR:   True

Error starting app
header->boot_flag: 0 ?= 0x55
Waiting in bootloader...

Could it be saved somehow?

Edited by Ren
Link to comment
Share on other sites

  • 2 weeks later...

OK, seems there's no support anymore I'm afraid. Does anyone have any idea how to de-brick Flirc 2nd gen? While it isn't displayed in device manager (or maybe it is buried somewhere deep in the devices tree?), here it seems to be stuck in the bootloader, so maybe it is not completely lost.

Link to comment
Share on other sites

  • 4 weeks later...
5 hours ago, EaZyCheaZ said:

I have the exact same error message and output on my test. I just bought this unit in march. I finally got my new man cave assembled and went to program my remote to the flirc and it's dead.

Hi man. I guess each case will be very individual, but I got mine fixed quite simply by moving Flirc into a different USB port and manually flashing older fw with flirc_util.exe upgrade dori.release.bin. I had to dig for an older release of fw here on forums, those are not readily available somewhere. After that it was correctly recognized by GUI, and properly flashed up-to-date fw, so I moved it back to the original USB port and I'm happily using it since. So I hope you're comfortable with command line and that solution will work for you too.

Link to comment
Share on other sites

i found a solution that worked. I ran "C:\Program Files (x86)\Flirc\flirc_util.exe dfu" to force it into upgrade mode and then opened the flirc app. It promptly completed the firmware upgrade it was stuck in the middle of and now my device is working.


Thanks for the reply though. Glad yours is working too. I really love these damn things. I have 4 of them :)

Edited by EaZyCheaZ
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...