Jump to content
Flirc Forums

Cannot Update Firmware on my Flirc


Recommended Posts

Hi all,

I hope someone can help me.

I purchased my Flirc 2nd gen (metal one) about a year ago to use with my shield tv and logitech harmony remote. Been running fine until recently, I decided to upgrade the firmware on the flirc but I cant. I updated the software on my PC (running latest version of Windows 10) to the latest Flirc but I get an invalid SKU remark and the device is disconnected in the Flirc app. I have attached a screenshot and a copy of the log as well.

The Flirc device is working, Windows is detecting it and I can see it listed under devices.

I tried it on different USB ports but it made no difference.




Link to comment
Share on other sites

  • 3 weeks later...

Man I'm wondering the same thing. I have 3 Flircs one new one and 2 older ones. The 2 older ones are the ones giving me there error.


error 1.jpg

error 2.jpg

error 3.jpg

Version is still the same after the update which says it was a success!

Why isn't there a direct link to the updated firmware in support? The option to manually update FW is there in the UI?

Had that available maybe we could fix our own damn problem!

Edited by flhthemi
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...