Jump to content
Flirc Forums

Keypress Delays after upgrading Firmware


Recommended Posts

(Skip to the bottom 5-6 lines for the actual issue, the rest of this is just me trying to provide as much info as possible).

I have 4 Flircs (3x V1, 1x V2), and 3 Kodi Boxes (2x HTPC, 1x Raspberry Pi), and 4x Comcast Remotes (1x Older Style and 3x of the slightly newer style - one is broken). 

Recently I had to replace one of the newer style remotes due to physical damage to the older one. Upon pairing the new remote to a Flirc V1, it prompted me to upgrade the firmware so I figured why not. Did that, and tried to setup the new remote to no avail. It looks like the new remote only uses IR for a few functions (When on the 'TV Setting'), because it processes every key as the same key when in the 'Cable' setting, despite looking the exact same as the other remotes of that style that I had.

Before noticing that was the issue, I took my Flirc V2 and tried to pair it with the newer style remotes (Not the newly purchased one) to see if it worked, as the other newer style remotes that I had seemed to work OK with the Flirc V2. It was still giving me the same issue with the keypresses, so I figured I'd give it a firmware update and see if that helped at all. Unfortunately it didn't and this was when I started to realize that the newest remote just isn't going to work.

So then I went back and tried to re-pair my Flirc V2 to the remote it was previously connected to. That worked just fine, all the buttons registered ok, great. I noticed while doing so there was a fix for the Flirc being unresponsive when waking from sleep, so I figured I'd go back and update all of the other Flircs I have as well (Except one of them, which I still haven't touched as it works flawlessly, no sleep issues, nothin).

Now, I've got 3 Flircs (2x V1s and 1x V1) and two different types of Comcast Remotes (1x Older 2x Newer), and the only one that hasn't had the firmware upgraded settings changed on it within the newest software version is the only one that doesn't seem to have some pretty severe delays between keypresses. Whether I'm pressing a button repeatedly, or whether I'm holding 'Down' to scroll through an episode guide, there's a solid ~half a second delay between each time it registers. In the past I could scroll through ~1000 channels in about 20 seconds. Now it takes nearly 3 minutes.

I see that the V1 flirc (fw 3.6.0) that I worked on today does still have the Interkey Delay option. When I set this to 6 or 7, it does seem to resolve my issues a bit. Not perfect, but much better than at 0-3. The delay is consistent no matter which remote, or which TV.

Edit: After testing a little more, the flirc V1 that I did not touch today is ALSO on 3.6.0, but does not have the delay issues on either HTPC. It is also set to Interkey 7, but even after loading it into the software (No changed settings, mind you) it still works flawlessly.

Likewise with the V1 Flirc on fw 3.9.0. Once i changed that interkey delay, things seem to work a little better. Probably about 45seconds to scroll through ~1000 channels (Compared to the ~20s / 3min times previously mentioned).

But with the V2 (4.6.3) that's not an option and it's unfortunately become pretty useless for me, as it takes me about 5 minutes from start-up to finally actually finding the channel or TV show due to how slow navigating the menus has become.

It should probably also be mentioned that I upgraded the Flirc GUI today from ~v2.x.x to 3.22.4. Essentially any Flirc that I've worked on since making that upgrade, has had the delay issue.

Is there any repository of older firmware versions, or older software versions, where one could download a few to try them out? I unfortunately have no recollection of what FW I upgraded the V2 FROM, so I don't know exactly which one I need to request.

Edited by dnalloheoj
Link to comment
Share on other sites

  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...