Jump to content
Flirc Forums

New Firmware, can't program remote properly any more. (All buttons record simultaneously)


Recommended Posts

Hi, I had problems with Flirc in the past, but managed to get it to work with this remote. Now Kodi 18 came out and I updated my Libreelec to version 9. Some buttons started to misbehave so after a few years of reliable use, I plugged the Flirc into my Windows 7 PC and tried to reprogram it. The prompted firmware update failed at first, I had to restart the program, it then resumed the upgrade and was, apparently, successful. I continued to try and program the remote, but for some reason, after the first assigned action to any key, every button on the remote now does the same action, no matter where it is placed. When I try to remap another key, it says it is already assigned. Sometimes, seemingly at random, it will let me bind another key.

Neither distance to the remote, nor the angle seem to matter. I vaguely remember reading up on previous problems that I should record it at roughly the distance I want to use it, which I did. But I also tried going really, really close, same result.

I had relatively fresh batteries in there when I first tried to record it, then put new ones in, nothing changed. The PC is the same (as in, the exact same Windows installation, I merely updated the software), the remote is the same, the Flirc device is the same, only the version of the software and firmware changed. I also tried to clear the configuration.

PS:  As for the firmware upgrade, it was apparently successful, but I still tried to resolve the issue of having to close and open the program back up to make it succeed, without luck. The support site said to go into device manager and see if the Flirc device is installed properly, it's not, not even listed. I tried to make it search for new hardware, nothing came up. I installed the *.inf files manually (add legacy hardware), it adds the device with the yellow ! on it, nothing changes though. I tried to force a firmware upgrade on an Ubuntu box, went without issue, but the exact same problem occurs when trying to record buttons.

PPS: Another remote, which I do not plan on using, seems to work, except for a few keys, though this may be the fault of the remote.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...