Jump to content
Flirc Forums

Metel Flirc Bug


Recommended Posts

Update: 2/4/17

On win10, and macOS Sierra 10.12.3, Everything works just great on both metal Flirc and SE.


test update edited2:

Problems are solved with WIN10 ALL FUNCTIONS ARE WORKING AS INTENTED with the latest firmware update.  Just Uninstalled and re-download it, once connected the update message showed up.

On my macbook pro, Only thing doesn't work is sleep and wake.

On my hackintosh build(sorry I don't really own a mac pro/mini/iMac), everything functions as intended.  Only thing flaky is when I register sleep, the prompt would show up with minor delay, and "Shutdown" actually functions as "Sleep".  It'd Very Likely due to my own system setup and has nothing to do with Flirc.


I just got the two Flirc ordered this week.  The new Metal one and the SE.
I so far has only tested the Metal Flirc on my desktop windows10 and a macbook macOS Sierra.

Issue for Windows 10:
1. Hibernate is DISABLED, I can use the GUI, tab Controllers --> Media Key, pair up the power button which works no problem to put the computer to sleep.
However, I cannot wake it up by using any mapped key or the "Wake button" under Full Keyboard.

2. I cannot change any settings in the advanced setting at GUI.

3. I cannot use the flirc_util.exe command(see image attached)
The exe file runs fine by listing all the commands.  The only one that can be run is "wait" which will run into waiting and if I re-plug Flirc, it will say FW Detected.
But the rest of the commands in any way, responds with device disconnected, can't run command. And the GUI does say Connected, plus I am able to map keys no problem.

I have tried to install the USB on both 2.0 and 3.0 ports.
The normal press any key on keyboard or mouse works fine either sleep or hibernating.


Issue for macOS Sierra:
1. Pairing keys are no problem but does not work.  No input at all, but they are paired up according to GUI.

2. The advanced setting does not work, just like Windows.

I am not as familiar with Apple OS, not sure what to do at this point.


I am hoping this info can help both the developers and I getting this product to work properly.
Please let me know if you have any suggestion.


Edited by Cayprol
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...