Jump to content
Flirc Forums

Won't wake sleeping Windows 10 HTPC


Recommended Posts

Just bought a usb flirc receiver, and here's my versions of stuff:

Flirc GUI v1.4.4
Flirc driver v3.0.6.0

In the GUI, File > Advanced > [x] Sleep Detection is enabled. In Controllers > Full Keyboard, I mapped a signal to the Wake key. When the computer goes to sleep, pressing that button (or any other mapped flirc signal for that matter, e.g. arrow keys, enter, etc.) has no effect whatsoever.

So I opened the device manager and looked at libusbK USB Devices > flirc and saw that there was no Power Management tab. Then I looked under Keyboards to see four entries labeled HID Keyboard Device. All four of them have Power Management > [x] Allow this device to wake the computer enabled. I tried disconnecting flirc, and one if the keyboards disappeared. I figured out which of them was flirc's keyboard entry and double-checked that device-wake was enabled (it is).

Since none of that worked, I opened PowerShell (x86) as an administrator and ran powercfg -devicequery wake_from_any and saw flirc along with a lot of other device names.

Then I ran powercfg -devicequery wake_armed and saw this much shorter list:

    PS C:\Windows\system32> powercfg -devicequery wake_armed
    HID Keyboard Device
    HID-compliant mouse
    HID Keyboard Device (001)
    Killer E2400 Gigabit Ethernet Controller
    HID-compliant mouse (001)
    HID Keyboard Device (002)
    HID-compliant mouse (002)
    HID Keyboard Device (003)

I then tried to enable wake for flirc with disappointing results:

    PS C:\Windows\system32> powercfg -deviceenablewake flirc
    You do not have permission to enable or disable device wake.

(I tried the above with the 32bit PowerShell as well, just in case, but with identical results.)

I can't find any settings related to wake from USB in my BIOS, but I enabled Power On By Keyboard (with any key), Power On By Mouse (with any movement), and Platform Power Management for good measure. That said, since I can already wake from suspend by plugging in an actual USB keyboard and pressing any key, so I don't see how any of that would help anyway.

Also, for what it's worth, powering on a steam controller does wake the computer from sleep. But I bought this flirc receiver for the sole purpose of being able to wake my computer with my remote control as well, so it'd be really nice if it did that.

Can you think of anything I haven't tried?

Much appreciated,

Link to comment
Share on other sites

I'll add that it could be possible that the flirc receiver isn't getting enough usb power to do its job, but I'm not sure how to test this. Other devices (e.g. harmony hub, charging phone) work just fine via usb power from the sleeping computer, so I guess I think it's unlikely that this is the problem.

Does anybody know a way to know for sure?

Link to comment
Share on other sites


Flirc doesn't need much power so I don't think that is a problem. To be sure you could use a powered USB hub or volt/amp meter plugged into the USB port (usually called Charge Doctor, like this one http://usb.brando.com/usb-power-current-voltage-tester_p03434c046d015.html).

You don't need to enable "flirc" as a wake device using powercfg. This is not the source of the wake call. It uses HID keyboard interface to do that, so enabling "Allow this device to wake the computer" in dev manager for the correct keyboard device is the right way to go. I don't know what may cause the issue in your case. Maybe Flirc doesn't detect that the PC went into sleep mode for your specific hardware/software configuration. Can you test your Flirc on another PC? You don't need to install the Flirc software there, just plug it in, make sure that the option to allow waking up in dev mgr is enabled and check if it works.

You can also erase the wake button from Flirc. With sleep detection enabled and no wake button recorded any key that is recorded in Flirc should wake the PC.

Link to comment
Share on other sites

Ok! I don't think this is a sleep issue after all: I tested on an old Windows 7 laptop by plugging in flirc, waiting for it to auto-install the appropriate drivers (it failed on the third one which was actually called "flirc"—I don't remember the other two, but they were along the lines of "usb controller"), and then putting it to sleep.

I pressed a button (mapped to spacebar), and the laptop immediately woke up. I also tried opening notepad and pressing that button, and sure enough, it typed spaces.

But when I plug it back into my new Windows 10 machine, it doesn't send keyboard signals at all. Even when I keep the computer awake and open notepad, there is no response at all when I try pressing the "spacebar" button. So it isn't an issue of waking my computer—it's that it won't talk to my computer at all.

However, it still listens to signals while plugged into the Windows 10 machine. It is, after all, able to listen to and assign IR signals.

Not sure what info would be most helpful at this point, but I've attached a few screenshots from Device Manager. Please let me know if you have any other ideas.

Thanks for your help!

Screen Shot 2016-09-25 at 14.36.07.png

Screen Shot 2016-09-25 at 14.38.18.png

Screen Shot 2016-09-25 at 14.38.34.png

Screen Shot 2016-09-25 at 14.38.57.png

Screen Shot 2016-09-25 at 14.39.12.png

Screen Shot 2016-09-25 at 14.39.25.png

Screen Shot 2016-09-25 at 14.39.38.png

Link to comment
Share on other sites

I'm having the same problem, which has started a week or so a go, on my Windows 10 PC. It was previously working so maybe it was the Anniversary Update?

To summarise:

1) Sleep detection enabled. PC will not sleep when being sent the CTRL-ALT-S shortcut via Flirc remote to sleep the machine (this is a shortcut in my Start Menu). PC wakes fine from sleep using mapped Wake command on remote.

2) Sleep detection disabled. PC will sleep when being sent CTRL-ALT-S via FLirc remote. PC will not wake using mapped Wake command :(

So, looks like something has broken sleep detection.

Link to comment
Share on other sites

Interesting! For what it's worth, when I disable sleep detection, flirc still won't communicate any signals to my computer. Yet the GUI still works—I can use the Windows 10 machine to assign buttons that the receiver will recognize and pass on readily as long as it's plugged into my old Windows 7 laptop.

I feel like there must be some permissions problem somewhere, since flirc is communicating nicely with its assignment GUI but not at all with the rest of the OS.

Link to comment
Share on other sites

  • 5 months later...

Double check in device manager for me it showed up as HID-compliant system controller. I was looking under keyboards and mice and all were set to wake computer that's what had me confused. Once I figured out what it was labeled as and check the box it worked.


Edited by BigCatTeeter
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...