Jump to content
Flirc Forums

Mapping of keys on Harmony One


Recommended Posts

I noticed when I was programming my flirc that after programming period (.) and comma (,), when I tried to map w and O, they responded with period and comma.

I am using a Harmony One, configured for Samsung LN46C650L1F TV.

Yellow is programmed to Skip Back, which is comma (,)

Green is programmed to Skip Forward which is period (.)

C is programmed to o

B is programmed to w

Any ideas why this is happening?

To record perio and comma, I state:

flirc record .

flirc record ,

Should the command be different?


Link to comment
Share on other sites

Hi iainmacleod,

It may be that the code the signal the remote is sending is the same or similar. If you are using the GUI (which from the command line prompt you provided above you're not) it will show that the button is already recorded. Two things to try:

1) Use the Flirc GUI to program those buttons - see if anything unusual happens

2) Check in the harmony software that the buttons are definitely mapped to different functions

I may give digitalb0y and friendly message to see if he can help or suggest anything to do via command line if GUI option isn't viable to you (as he's very knowledgeable in those parts)

Pleasant regards,


Link to comment
Share on other sites

I think those commands look correct. Do the rest of the buttons still work the way their supposed to? I would try this:

flirc delete
...and press C, then repeat for B, green and yellow. That should make all four buttons blank, and then do your
flirc record <key>

commands again.

It sounds to me like the Samsung LN46C650L1F TV profile for your harmony might be sending the same IR info on multiple buttons. You could test this by clearing the entire mapping (save it first if you want to keep your mapping (flirc saveconfig <fliename>)) and then map nothing but your yellow, green, B and C buttons, and see if all four act the way they're supposed to. If remapping all four buttons results in the same odd behavior, I would try a different profile.

Good luck and please keep us posted!

Link to comment
Share on other sites

So I formatted flirc, and then recorded comma to B, and period to C. All worked fine, I then pressed the buttons that we thought may have a conflict, Yellow and Green (these were not programmed). Pressing them did not result in any action taking place on my XBMC machine, leading me to believe there was no conflict with the buttongs.

However when I decided to record w to Yellow I recieved the following error:

error: button exists

Then I decided to format my flirc, and reload a configuration. Seems my backup is blank!!!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...