Jump to content
Flirc Forums

Flirc totally bricked after Firmware upgrade?


Recommended Posts


today, I had a strange behavior of the Flirc.

After I changed the USB-port of the Flirc, it did not recognize any key presses from my remote. This did even commence, after I changed the port back.

I thought, that the programming might have been erased somehow. So I started the administration program on Linux, which was a rather old version (v1.2.2). I tried to reprogram the Flirc with my saved configuration file, what did not work at all (no error messages, just no result). So I tried to reprogram the keys by hand. The control program said, that the signals where already programmed, so I tried to delete them and reprogram them. First I tried to delete them one by one, what did not work. After I done it, it said that there is no memory left for further keys. So I tried to remove all programming and deleted the whole configuration ... which showed up the same result.

So after these results, I loaded the newest control program from flirc.tv (v1.4.4). I unpacked it and started it.It said, that there is a new firmware. So I said it should install it. After I did it, Several error messages showed up.

When I restarted the control program it always showed, that the firmware was old and said I could install a new one. But every try just had the same result.

When I start the new control program, it always gives these messages now:

Can't load 'test.ini'
[E] fl_product_type(717): unknown or unsupported variant
[E] fl_product_type(717): unknown or unsupported variant

And it asks me every time, if I want to upgrade the firmware. When I don't upgrade, I end in the disconnected state and can do nothing. When I upgrade, it does the upgrade and I can program some keys.

Programming of keys by hand did work (partly), but to reinstall the firmware every time is very annoying. Also it seems that something is wrong, since now I have to press every key on the control that I programmed two times to get one single reaction.

When I try to run the old control program (v1.2.2), I get these messages now:

[D] fl_open_device(130): Firmware v:3.7
[D] determine_iface(59): fw_state: firmware
[D] determine_iface(60): version: 3.7
[E] determine_iface(104): version not supported, loading def: ver1
CheckFirmwareVersion(402): hw version: 3.7
CheckFirmwareVersion(403): emb version: 2.300000
fl_close_device(325): closing device handle


As it seems to me now, my flirc has been (partially) altered by the new firmware, but this does not work correctly (since the control program always wants to replace it and the key programming does not work correctly (only every second press works now)).

This change seems to be irreversible, since the new program does not help and the old does even less, since it does not understand my flirc now.

So I fear, that the device is irreversibel broken now.


Or is there any method to revert the changes or install some working firmware correctly? My device is a little older (I bought it in the beginning of 2014) but I did not expect to brick it just by using a newer version of the control program!

Any help is appreciated!

Best Regards,



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...