Jump to content
Flirc Forums

FLIRC does not work for hours at a time, Debian Linux, flirc not ok

Recommended Posts

Hi, I'm pulling my hair out trying to debug my flirc devices. I have 3 flirc's for three different systems, all running debian bookworm. all three are intel nuc's, two of the systems keep throwing the same error. it comes back and usable after a day or so. other usb devices seem unaffected. During that time that specific flirc seem to work fine in a different system. other flirc do not work on the system with the error till some time after(when the orig flirc works too). reboots don't fix it, reinstalling the os doesn't fix it. changed remotes (from sony to off brand) doesn't fix it. flirc_util format, nothing. tried using the flirc program, still no luck.

installed by:
curl apt.flirc.tv/install.sh | sudo bash

needed to run/link for flirc_util to work
# ln -s libreadline.so.8 libreadline.so.6


$ uname -a

Linux hostname-here 6.1.0-9-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.1.27-1 (2023-05-08) x86_64 GNU/Linux

flirc firmware running:

Firmware Version: v4.9.3

SKU: Flirc 2.0 [dori]

Git Hash: 0xcb185bde


error being shown:

$ flirc_util unit_test

E] lib/libflirc/firmware/fw_4.0.c fl_ver4_set_interrupt(367): timeout
[E] lib/libflirc/firmware/fw_4.2.c _fl_unit_test(132): error recording test0
Flirc Not Okay

after it comes back:
i tend to need to reprogram afterwards, which i do by flirc_util record and not by loadconfig



so yeah, i don't know what to do .



help please

lsusb-v.txt flirc-unit-test-debug-true.txt my_flirc_log.txt

Link to comment
Share on other sites

  • 4 weeks later...


I've managed to make it work (1st time) on Debian 12, on a VM, I've also used 'curl apt.flirc.tv/install.sh | sudo bash' but that didn't work for me either.

Have you tried downloading http://apt.flirc.tv/arch/x86_64/flirc.latest.x86_64.tar.gz, extracting and copying this to the bin folder?

I also had to create the symlink for the lib

Created ini with: sudo nano /usr/bin/flirc.ini

Added rules with: sudo nano /etc/udev/rules.d/99-flirc.rules

chapas@Debian12:/lib/x86_64-linux-gnu$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 006: ID 20a0:0006 Clay Logic flirc
chapas@Debian12:/lib/x86_64-linux-gnu$ ls -alh libreadlin*
-rw-r--r-- 1 root root 642K Jan  3 20:49 libreadline.a
lrwxrwxrwx 1 root root   38 Jan  3 20:49 libreadline.so -> /lib/x86_64-linux-gnu/libreadline.so.8
lrwxrwxrwx 1 root root   18 Jun 28 17:29 libreadline.so.7 -> libreadline.so.8.2
lrwxrwxrwx 1 root root   18 Jan  3 20:49 libreadline.so.8 -> libreadline.so.8.2
-rw-r--r-- 1 root root 347K Jan  3 20:49 libreadline.so.8.2
chapas@Debian12:/lib/x86_64-linux-gnu$ flirc_util version
FW Version: v4.9.7
   SKU:     Flirc 2.0 [dori]
   Branch:  release
   Config:  release
   Hash:    0x1DE23EB8

chapas@Debian12:/lib/x86_64-linux-gnu$ flirc_util unit_test
Flirc Okay

I've used the flirc_util to map some buttons that I couldn't map on the GUI.




  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...