Jump to content
Flirc Forums

Streacom Gen 1 no longer working after firmware update (3.11.0)

Recommended Posts


Not sure if this forum is still alive but here goes nothing!

I have a Flirc Streacom edition ... Gen 1 and it's been a faithful little device for years. Recently, I purchased a new TV and I wanted to remap the buttons to a new remote... and that's when the fun began. I found the flirc app was showing as disconnected despite the device still functioning normally with my old remote. I followed the instructions for uninstalling and reinstalling the driver but to no avail. The driver was installed and showing as healthy in the device manager.

I tried the command line utility flirc_util but it just gave me errors "Access is denied. Unable to contact device".

I tried using zadig and it shows the flirc (interface 1) as being on libusbk (v3.0.7.0). It allowed me to upgrade to v3.1.0.0 but it didn't help.

So I booted up Ubuntu and I tried to get it working on a live USB. I managed to symlink libreadline.so.8.1 -> libreadline.so.6 and got the software to load but it too showed disconnected. I tried flirc_util and it offered some colourful language when doing a `./flirc_util unit_test`  ... saying it's f**ked. I ran `./flirc_util dfu` and upon starting the GUI client it immediately updated the firmware! I recorded the new remote and shutdown the machine, booting back into windows. 

At this point I lost functionality... neither the old or new remotes would work although I could still power on. In Windows, I loaded the GUI and once again it showed as disconnected. I loaded zadig and found a 2nd interface "flirc (interface 0)" in the list which was using WinUSB. I updated it to libusbK (v3.1.0.0 - was the only option) and GUI immediately started a firmware update, flashing to 3.11.0. I could also use the command line utility and started trying to remap keys. The recording is successful but the keys cannot be played back! I ran the `flirc_util format` in an attempt to restart but this only resulted in the loss of the power button. I had to boot back into ubuntu in order to re-record that key press using flirc_util. I could record left, right etc... but they don't work even though the recording is successful!

Long story short, I have a flirc streacom edition gen 1 on 3.11.0 with libusbK 3.0.7, Flirc 3.26.5 and no working remote. 

Any ideas would be greatly appreciated! (especially if anyone knows what drivers it should be using on the 2 interfaces!!!).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...