Jump to content
Flirc Forums

URC MX900 programmable remote and "Button already exists"


Recommended Posts

Just got my first flirc a couple days ago, and my hopes were high.  Not so high at the moment.


I'm running the latest software (v1.2.3) on a Windows 7 x64 HTPC, and the latest firmware (v2.4) on the flirc.


My Home Theater setup consists of a number of devices, all of which are controlled by a Universal Remote Control MX900 I've had for several years.  It can do both IR directly (which I don't use any more) and RF converted to IR via a URC MRF-250 device.  It converts the RF signal into an IR signal and sends it via emitters mounted on/near the amp/projector/DVD/CD/etc in a cabinet built into the rear wall.  (Sounds awkward, but it's open in the back to one bay of the kitchen cupboards.)


I have programmed the MX-900 with a preset for something I don't have, the VIP 722 DVR satellite/DVR from DIsh Network.  Lots of buttons available to work the magic on XBMC.


I first tried programming the flirc on my desktop PC (also running Windows 7 x64) since it's a lot easier to do all the MX900 programming there rather than on the projection screen.  Anyway, when trying to get a code into flirc from the MX900 using its IR capability, from a cleared configuration, I always get the message "Button already exists".  (I started with a cleared config, buy the way.)  It does the same thing when running the MX900 in RF mode with the IR emitters.


The very interesting thing to note is that every last component remote - all IR devices - program the flirc perfectly!

  1) the HDMI switch - HS-41A0

  2) the Blu-ray player - LG BD550

  3) the CD player - Sony DVP-NC85H

  4) the amplifier - Arcam Alpha DAVE

  5) the projector - Epson PowerLite Pro Cinema 1080p


Every last one!  But not the (relatively) expensive programmable remote.


I'd be perfectly happy to use one of these controllers - say, the CD player remote - except there's no practical way to get its IR signal behind me and into the virtually opaque component cabinet that houses all electronics, including the HTPC.


I hope there's a simple fix for this.  The flirc sounds like such a neat gadget.



Link to comment
Share on other sites

I tried the old laptop, and as I expected, there was no difference.  In messing around, though, I found that a few of the buttons DID program the Flirc!  The buttons that had been set up as "punch through" (volume up & down, and a handful more from the amp control page) worked just fine.  That got me to thinking.   ;)   Since all my individual remotes worked, maybe it was my selection of a satellite DVR profile that was the problem.  Well, I don't know what's so different about them, but a lot of other device profiles work just fine, so I'm planning on using one for a Tivo, or a CD/DVD player, anything with a lot of different codes available to use.  Now the fun can begin!   :D


If anyone reads this that knows what makes the DVR profiles unusable, I'd sure like to know.

Link to comment
Share on other sites

Now that I have the remote programmed and sort of working with my newly built HTPC, I have quite the remaining mystery.  It appears that the buttons are recognized roughly every other time I push them, although it's not always that way.


I noticed it first in MediaPortal that I'm working on using to manage the HTPC.  To see more exactly what was happening, I used Notepad, although I can only reasonably use the number keys for experimenting there.


Except for the number "1", which works perfectly every time (?!), the other numbers all misbehave.  There appear to be several patterns:

  1) When pressing the same number over repeatedly, it works every other time, e.g., pressing "222222..." displays "2<nothing>2<nothing>2<nothing>..."

  2) When changing numbers every time, they all work, e.g., pressing "2345678..." displays "2345678..."  (or "2323232" and all the other patterns I tried)

  3) When pressing the same number twice followed by another number, it behaves in two different ways, e.g., pressing "22334455" displays either of the following patterns:

      (variant 1) "2<nothing><nothing>34<nothing><nothing>5"


      (variant 2) "2<nothing>3<nothing><nothing>45<nothing>"


This is a real stumper.  I'd sure like to know what's going on in the firmware to cause this.


Has anyone else had this happen?  I can't think how to search for this.


Will the developers notice this plea for help, or is there something I must do to bring it to their attention?


Holding my breath....




OK, breathing normally again a couple hours later.


For whatever reason, and I assume it's similar to my previous problem where the Satellite DVR profile failed but the DVD profile worked, the Arcam DVD profile I chose for the HTPC was causing the "number problem".  What it was, I don't have a clue, but changing to a Denon DVD profile has fixed the "number problem".  Since I haven't yet tried all the rest of the functions, an abyss may still lie ahead.

Edited by neumanncj
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...