Jump to content
Flirc Forums
ariflirc

FLIRC + Harmony + Multiple activities: non-FLIRC activities shutdown turns HTPC on

Recommended Posts

I"m using FLIRC SE, with a linux-based Kodi HTPC build (mini ITX fanless etc). This build has been working great for a year now.

The FLIRC SE is only connected to USB - without the connection to the Power Supply, as I only need it to wake the HTPC from "suspend to RAM" (S3) state, I don't need it to wake the HTPC from S5.

The remote is a Harmony Hub with the simple RF remote (they call it Harmony Companion these days).  I use it to control the HTPC (Kodi), the Smart TV  and my Receiver.

Overall, it works great but there is one annoyance thought that I could not work around after I added more than one "Activity" to the Harmony Remote.

 

Activity 1 is "HTPC" (FLIRC)

In Harmony > Setup > Devices >  FLIRC > power settings, I use "Use two different buttons", and using FLIRC's programming utility, I mapped "AspectRatio" to the "wake" event. For power off, I used the programming utility to map to the "F12" key. I did  this because I use some custom script that gets triggered by F12 and check if it's OK to suspend, and later trigger suspend.

The FLIRC device in Harmony is setup to "Turn off when not in use"

This setup works fine: HTPC suspends and wakes  perfectly.

 

Activity 2 is "Netflix", launching  my smartTV's Netflix client.

This activity does NOT include FLIRC in it; it only controls the TV and the Receiver.

It also works fine, turning on and off just works.

 

Here's the problem:  when I turn OFF Activity 2 "Netflix", the HTPC turns ON for some reason. Eventually, Kodi's idle timer will suspend it again. But this is annoying.

It seems like FLIRC is catching infrared events that the Harmony hub is sending to the TV or the Receiver, and then sending some keypress to the HTPC, and the HTPC  is waking up on any keyboard keypress.

 

Wondering if anyone ran into this issue and was able to solve it.

Ideally, FLIRC should NOT be sending ANY keypress to the HTPC while the HTPC is in suspend mode except for the "Wake" keypress when it is received by IR. Is there a way to enforce this?

 

Share this post


Link to post
Share on other sites

self reply: issue solved

- Upgraded the Flirc SE firmware to the latest available for gen1: v39

- Re-recorded the Wake key (Harmony is programmed to send "FLIRC > AspectRatio" as the power-on command.

made sure that "sleep_detect" is activated.

It just worked; turning off other Activities like Netflix will no longer cause the HTPC/Flirc to wake up. Before, I had v37 and it seems sleep_detect wasn't working.

 

Edited by ariflirc
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×