Jump to content
Flirc Forums

Search the Community

Showing results for tags 'downgrade'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Flirc forums
    • Getting Started with Flirc
    • General Questions
    • How To
    • Show Off
    • Remote Controls
    • Ideas and Suggestions
    • Bugs

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


Interests

Found 1 result

  1. Hi All, I just bought myself a Flirc because of the lack of 3rd party IR support in OSX. When installing and configuring the Flirc device I've updated the Firmware to 3.8 (GUI 1.4.4) and then started configuring my Microsoft MCE (Model 1039) RC6 Remote. While configuring I get an error message saying 'Button already exists' when recording some of the buttons on the remote. This is happening for my Up and Down buttons, it seems the Flirc device reads the IR signals sent by my remote as being the same for some button pairs (Up/Down, OK/Back). After searching this forum I fiddled around with the Advanced settings and I could not resolve the issue. One forum topic mentioned something about downgrading the Firmware so I thought lets try. After downgrading the Firmware to version 3.1 (GUI 1.2.8) on OSX with the 'flirc_util dfu' command and starting the GUI which then allows to install the lower Firmware, I noticed on 3.1 the RC6 behaviour is perfect, no more duplicate button messages and everything seems fine. I still have to record all the buttons twice because of some RC6-specific difficulties mentioned in other topics, but that's no problem. When doing some more testing I noticed the Flirc device would not wake up my Mediacenter from sleep, so I searched this forum again and tested all the configurations I found in different topics regarding sleep issues (Sleep detection and different suspend/wake/power button mappings) but none of them solved my problem. I am testing my Flirc device on 2 machines, one Mac Mini (2011) running OSX El Capitan (10.11.5) and one MacBook 12" (2015) also running OSX El Capitan (10.11.5). When putting the machine to sleep I can wake it again using my remote for about 1 minute, after this minute the machine does not respond to any buttons. On the Mac Mini I can see the Power LED going from steady to blinking when putting the machine to sleep, and this takes about 30 seconds. It seems that when the Power LED is still steady I can wake it using the remote, and when the LED goes blinking I can not. Because I'm very curious I updated the Flirc's firmware to 3.8 and tested the Sleep/Wake behaviour on this firmware, and on 3.8 the wake works just fine! Even after this one minute and with the Power LED blinking on the Mac Mini I can successfully wake it up using one of the desired Flirc configurations (one button with wake, or all buttons without wake). So now I'm in the position where I want the FW 3.1 RC6 behaviour but I need the FW 3.8 Sleep/Wake behavior so I'm kind of stuck here and I think I need some assistance from Flirc developer @jason. TLDR; On FW 3.1 RC6 is fine but Sleep/Wake doesn't work, on FW 3.8 RC6 is broken but Sleep/Wake works fine. Help!
×