Jump to content
Flirc Forums

maestro_alubia

Members
  • Content count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About maestro_alubia

  • Rank
    Curious Flirc-er
  1. "Invalid Device SKU" when updating Firmware

    I also tried on Linux now, and this is the output of the GUI during attempted firmware upgrade: fabian@gauss ~ $ Flirc Can't load 'test.ini' [DEVICE] Uploading [D] lib/libflirc/bootloader/bl_3.3.c fl_ver_upload_fw(387): invalid image, incorrect sku [D] lib/libflirc/bootloader/bl_3.3.c fl_ver_upload_fw(388): File Device [D] lib/libflirc/bootloader/bl_3.3.c fl_ver_upload_fw(389): ---- ------ [D] lib/libflirc/bootloader/bl_3.3.c fl_ver_upload_fw(390): Flirc 2.0 [dori] Flirc 2.0 [dorir [D] lib/libtransport/transport.c _dev_send_cmd(243): Command error: 128 [D] lib/libflirc/bootloader/bl_3.3.c bootloader_enter_app(197): Image CRC mismatched [D] lib/libflirc/flirc_driver.c fl_upgrade_fw_ext(1087): upload firmware failed [D] lib/libflirc/flirc_driver.c fl_major_version(391): something bad happened [D] lib/libflirc/flirc_driver.c fl_minor_version(381): something bad happened [D] lib/libflirc/flirc_driver.c fl_patch_version(401): something bad happened [D] lib/libflirc/flirc_driver.c fl_major_version(391): something bad happened [D] lib/libflirc/flirc_driver.c fl_minor_version(381): something bad happened [D] lib/libflirc/flirc_driver.c fl_patch_version(401): something bad happened It appears, that somehow the Device responds with "Flirc 2.0 [dorir" instead of the expected "Flirc 2.0 [dori]". Strange... fabian@gauss ~ $ flirc_util sku product sku: Flirc 2.0 [dorir
  2. "Invalid Device SKU" when updating Firmware

    I just got a brand new FLIRC (the new with the metal case) and wanted to configure it (on Windows 10) I downloaded and installed the latest version 2.6.4. After successful installation the GUI detected the FLIRC and offered a firmware upgrade which I accepted. I suppose something went wrong here, cause it then showed "Invalid Device SKU". Everytime I now start the GUI it first shows "upgrading firmware" and then again "Invalid Device SKU". Any idea, what the problem is here? The Device Log shows nothing and the "Advanced" dialog is just gray. I also tried on Windows 7 and MacOS with exactly the same results. Please let me know, if you need more information or if I should try something else.
×