Jump to content
Flirc Forums

dharrah

Members
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About dharrah

  • Rank
    Curious Flirc-er
  1. I have a v1 Flirc (FW 3.08) and just got a v2 (FW 4.024). The remote I'm using is a DirecTV RC64RB. Both of the Flirc devices are continuously displaying the 'button already exists' message. I've tried the various inputs from the switch at the top ("DirecTV Logo"; "AV1"; "AV2"; "TV") and they actually act a bit differently. For example, while in 'TV' mode, I am unable to set each number from the keypad without seeing the 'button already exists' dialog. However, if I switch to the 'DirecTV Logo', I can successfully map each number. The one area that fails regardless of your remote mode is "Volume". Once you map one of 'mute', 'Vol+', 'Vol-', the dialog will pop for the subsequent attempt. I've tried uninstalling/reinstalling as mentioned above with no success. I've tried different USB ports and I've ensured that I'm not pointing directly at the Flirc device (also mentioned above). I'm simply unable to map this remote. I configured the 'TV' input for major TV brands such as Sony, Samsung, Pansonic, and Pioneer. Tried 2 or 3 codes from each brand. Same issues across the board with both devices. Please see attached for log files of this event. In each log I simply map 'mute' successfully and then attempt 'Vol -' which results in the error. Then I exit. Flirc_v2.txt Flirc_v1.txt
  2. I am running Raspbian Jessie on a RPi 2 and have my Flirc device plugged in. This device works 100% fine under OpenElec as well as RasPlex. I've verified through /var/log/syslog that the device is recognized but I do see the following error: Jul 9 20:21:46 raspberrypi kernel: [ 453.014807] usb 1-1.4: new low-speed USB device number 7 using dwc_otg Jul 9 20:21:46 raspberrypi kernel: [ 453.129171] usb 1-1.4: New USB device found, idVendor=20a0, idProduct=0001 Jul 9 20:21:46 raspberrypi kernel: [ 453.129201] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0 Jul 9 20:21:46 raspberrypi kernel: [ 453.129217] usb 1-1.4: Product: flirc Jul 9 20:21:46 raspberrypi kernel: [ 453.129233] usb 1-1.4: Manufacturer: flirc.tv Jul 9 20:21:46 raspberrypi kernel: [ 453.154323] input: flirc.tv flirc as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4/1-1.4:1.0/0003:20A0:0001.0004/input/input3 Jul 9 20:21:46 raspberrypi kernel: [ 453.206096] hid-generic 0003:20A0:0001.0004: input,hidraw0: USB HID v1.01 Keyboard [flirc.tv flirc] on usb-3f980000.usb-1.4/input0 Jul 9 20:21:46 raspberrypi mtp-probe: checking bus 1, device 7: "/sys/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4" Jul 9 20:21:46 raspberrypi mtp-probe: bus: 1, device: 7 was not an MTP device If I navigate to the Flirc utility directory (../Downloads/release/rpi/flric_util) I am able to successfully verify settings, keys, and versions. I can even delete and record keys through this interface. However, when I push the same keys (programmed a remote key to '0' for testing), nothing happens. I can take the Flirc out of the RPi and plug it right into Windows, and the key press results in '0' on the screen. Any ideas? I've googled all I can and am not finding any solutions. Thanks in advance!
×
×
  • Create New...