Jump to content
Flirc Forums
papreston

Flirc XBMC Add-on in Raspbmc?

Recommended Posts

Hi

 

I can't get the Flirc to show as "connected" in the XBMC add-on in the Raspbmc!  Does anyone have this working?  The Flirc is working, I used another PC to do most of the setup.

 

Thanks

Share this post


Link to post
Share on other sites

Same problem here. I actually had to set the Flirc plugin to load on start up to get it to pull up the GUI. From there I can use my remote to highlight buttons, but when I go to program them it says "connect flirc". I hate to have to fire up the old windows dinosaur to program this thing for one little button. Help would be appriciated 

Share this post


Link to post
Share on other sites

Sorry you are having trouble... I don't have a Raspberry Pi to test, so I don't know how much I can do personally, but does the Flirc GUI and command line utility work on your system?  Perhaps knowing whether those are working and it's only the XBMC plugin that's failing, or if other elements are also having trouble might make it easier for Jason to narrow down what's missing on your system that is already present on other Linux systems.  The Flirc Add-on has been really reliable on my XBMC box, which is an Ubuntu 12.0.4 system.  Also, what version of the Flirc software and firmware are you running?  And can you pastebin an XBMC log that includes the Flirc Add-on failure?  Do you see a failed script error message in XBMC or does it only refuse to connect to your Flirc and otherwise run without error?  Thanks!

Share this post


Link to post
Share on other sites

Running a RasPi (Rev. 2) with OpenELEC 3.2.4 and have no problems using the plugin.

 

How did you install it in xbmc, via zip or did you add the flirc-repo?

Maybe you have installed via zip-file and it was partly corrupt.

Try to deinstall the plugin, add the repo and install the plugin out of the repo again, maybe it helps!?

 

To install a repo, go to settings->addons-> add source and enter "http://xbmc.flirc.tv" (without quotes) and name it e.g."flirc".

Then choose and install the plugin as usual.

Share this post


Link to post
Share on other sites

Running a RasPi (Rev. 2) with OpenELEC 3.2.4 and have no problems using the plugin.

 

How did you install it in xbmc, via zip or did you add the flirc-repo?

Maybe you have installed via zip-file and it was partly corrupt.

Try to deinstall the plugin, add the repo and install the plugin out of the repo again, maybe it helps!?

 

To install a repo, go to settings->addons-> add source and enter "http://xbmc.flirc.tv" (without quotes) and name it e.g."flirc".

Then choose and install the plugin as usual.

I'd be OK switching to openelec, as Ive been banging my head trying to get it to work on my Raspbmc - But my core source is a windows MCE box - so I need pvr.wmc to work and I also need playon client to work.  Is it possible to run pvr.wmc on Openelec - I am not finding a lot of info on that.

 

thanks.

Share this post


Link to post
Share on other sites

Sad to say, that i have no experiences using PVR in xbmc yet.

As i read in the wiki (  http://wiki.xbmc.org/index.php?title=Add-on:PVR.WMC ) the pvr-wmc plugin is not listed under supported systems.

 

But you can give it a try by downloading the zip file and install it manually. Maybe this works for you.

 

OpenELEC is a nearly closed system, so you have not much possibilities to modify without the hassle of ssh & co.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...