Jump to content
Flirc Forums
Sign in to follow this  
chitza

Button already exist

Recommended Posts

chitza    0

I map one remote button ("Up") to the Up key. Then I try to map the Down button to the Down key. I receive the "Button already exists" error.

To confirm, I just press any of the directional keys and the "Up" key on the Flirc GUI lights up.

flirc_util version v2.3.0 [v2.3.0+]
Firmware: v4.0.10 [0xEEC0BEC4]

Remote profiles I've tried

  • Samsung TV remote
  • Denon AVR remote
  • Harmony 650 remote, Panasonic TV profile (as suggested by a Flirc support page)
  • Harmony 650 remote, Plex Plex Player profile
  • many other remote profiles on Harmony 650


I'm exhausted, I've tried so many profiles that I think I'm going to just give up on Flirc :(

For the record, this is the output of flirc_util.exe settings

 

flirc_util version v2.3.0 [v2.3.0+]
  Firmware: v4.0.10 [0xEEC0BEC4]

Settings:
  sleep detection:  NA
  noise canceler:   NA
  inter-key delay:  NA
  seq. modifiers:   NA
  variant:          Flirc
  builtin profiles: NA
  Memory Info:      NA

Recorded Keys:
Index  hash       ID   key
-----  --------   --   ---
    0  764C1A35   01   down
    1  DDAA14B5   01   left

 

Edited by chitza

Share this post


Link to post
Share on other sites
yawor    57

Can you add Flirc/Kodi to your Harmony and test if Flirc recognises each key separately?

Share this post


Link to post
Share on other sites
Andaho    0

I've also experienced this issue. I first resolved it by plugging flirc into a second PC, and then I was able to program it fine, for a little while... Then it started doing it on that PC too... I then uninstalled and re-installed the flirc software and found it works fine for one full programming.

The "Button already exists" error returns if I try to re-program or add additional buttons - but it is always fixed by uninstalling/re-installing the software. - Annoying, but it worked.

So try uninstall/re-install and see if that works for you?

Share this post


Link to post
Share on other sites
BegetaZ    0

Thank you, I managed to solve my issue, however, my first try of reinstalling the app was unsuccessful. After it, I unplugged the flirc usb ir and uninstalled the app. I then installed the app again. I started the app and then plugged in the usb. I also plugged it in without using a usb extension cord for razer headphones which I used initially to get the ir in line of sight. Everything works great now and I do not have an issue with ir line of sight. Thank you very much! I will paste my reply in the thread you linked in case someone finds it helpful as it is also a new thread.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×