Jump to content
Flirc Forums

flirc_util Debian download needs outdated libreadline, git compiles ok but just segfaults


Recommended Posts


I just bought a Flirc USB device (Dori version) to use with a Dish Network 20.1 remote to control Kodi on headless Debian Linux. First, I added your repo and installed Flirc from that to a test laptop that has a desktop environment installed. The first thing that happened when I ran Flirc was I got prompted to update the firmware to 4.9.3, which I accepted. There's no profile for my remote so I tried toggling around the different built-in profiles to get a good keymap for Kodi setup. That didn't pan out very well so I decided to make my own custom profile using flirc_util to map the exact keycodes to corresponding remote buttons.

I downloaded Linux Generic latest (flirc.latest.x86_64.tar.gz), which contained Flirc/flirc_util 3.25.3. Unfortunately it depends on libreadline6, which is unavailable as Debian stable is currently at libreadline8. So, instead I downloaded and compiled the git sdk flirc_util. Unfortunately it just segfaults when you run it.

I'd prefer to compile git and have it work but if nobody can look into the segfaulting, could someone please update the "latest" Linux package against current Debian stable, or re-package it as a snap/flatpack/appimage so it will just work (hopefully) without dependency problems?


  • Like 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...