Jump to content
Flirc Forums
Bone

Flirc wakes pc by itself

Recommended Posts

Hi guys I'm having trouble with my flirc waking my pc (acer revo r3700, openelec 3.2.4) from suspend by itself. I have enabled sleep detection and assigned a wake button on my remote. This wakes it as it should. I left it in suspend last night before I went to bed an it was awake in the morning. Before I got in bed tonight I wrapped the flirc in tin foil and set my pc to suspend to see if it's still in suspend in the morning. Any Ideas? 

Share this post


Link to post
Share on other sites

It's a HP mediasmart tv remote which uses mce signals i think. I had to program each button twice to sort it from missing every other button press.

 

What exactly do you need? I'm running the latest gui and firmware. The button configuration? 

Share this post


Link to post
Share on other sites

After leaving it in suspend last night with the flirc wrapped in tin foil it was awake when I got up this morning.

I unplugged the flirc and put it in suspend before work today to see if it's still like that when I get home.

Share this post


Link to post
Share on other sites

Here is your configuration: 

 

flirc_util version v1.2.2 [v1.2.2-13-gc107673+]

  Firmware: v2.3

 

Settings:

  sleep detection:  Disabled

  noise canceler:   Disabled

  inter-key delay:  6

  state:            0

  builtin profiles: Enable

 

Memory Info:

  keys recorded:  72

  keys remaining: 97

  memory used:   74%

 

Recorded Keys:

Index  hash        key

-----  ---------   ---

    0  77E20A13    F4

    1  37A6D1B2    F4

    2  7BA80BB8    F3

    3  3B8C8611    F3

    4  5A47BC68    tab

    5  1A2B37C2    tab

    6  19B7D2BA    F7

    7  D98A955E    F7

    8  F8B6D2BA    F6

    9  B88A955E    F6

   10  F897EE73    wake

   11  B86BB117    wake

   12  F83CF522    F5

   13  3869327F    F5

   14  BBEA3188    F2

   15  FB06B72E    F2

   16  99F746C3    c

   17  D923841F    c

   18  B8FA34A3    i

   19  F82672FF    i

   20  DA2637C2    F1

   21  1A43BC68    F1

   22  193DF522    u

   23  5969327F    u

   24  99D7C620    return

   25  D903047D    return

   26  3872835E    return

   27  789EC0BA    return

   28  FCFFB1D3    backspace

   29  3C0CC3B1    backspace

   30  D9A29BD0    p

   31  19CFD82C    p

   32  193FF0D2    f

   33  596B2D2F    f

   34  DAA47327    r

   35  1AC1F8CD    r

   36  376775D7    space

   37  77A3AE37    space

   38  782DB499    x

   39  B859F1F5    x

   40  77233EEF    up

   41  B75F774F    up

   42  B8D9A083    down

   43  F805DEDF    down

   44  D9731B23    up

   45  19A0587F    up

   46  9AA9CA85    down

   47  DAC54F2C    down

   48  FBADCA85    left

   49  3BCA4F2C    left

   50  DAADCA85    right

   51  1ACA4F2C    right

   52  16DDD665    1

   53  561910C6    1

   54  77E1D665    2

   55  B71D10C6    2

   56  56E1D665    3

   57  961D10C6    3

   58  F781E965    4

   59  37BE22C6    4

   60  3898E222    5

   61  78C41F7F    5

   62  B7F5E865    6

   63  F73122C6    6

   64  96F5E865    7

   65  D63122C6    7

   66  774226B5    8

   67  B77E5F15    8

   68  B838F522    9

   69  F864327F    9

   70  55760237    0

   71  95C27B8A    0

 

So I would pay attention to the doubles. You have double:

 

return

Down

Up

 

I don't know if this was intentional, or if noise was recorded. If not, delete those. Have you tried enabling the noise canceler?

Share this post


Link to post
Share on other sites

Hi the double return was intentional as i have an ok and an enter key. The up and down wasn't. I'm sure I've got the sleep detection enabled as i have set a wake key. I'll edit all of this and try again.

 

How do i get the config like you have posted it above?

 

Thanks.

 

Toby

Share this post


Link to post
Share on other sites

I've redone the whole set up and the up, down and enter keys are intentional. Can you check my config to make sure sleep detection and noise filter is enabled please or tell me how to do it. Thanks

 

Now off to test it  :) my_flirc_config.fcfg

Share this post


Link to post
Share on other sites

Sorted. I did tick the sleep detection box but when I checked after it wasn't so I re enabled it and that fixed my problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...