Jump to content
Flirc Forums
samy

Problem programming Play & Pause for WMC

Recommended Posts

Having trouble trying to program Play and Pause for Windows Media Center. i seem to be able to program all functionality, except for these 2. GUI says "recorded successfully", but when i try to use the buttons, nothing happens.  I've also tried using different buttons on the remote (ie not Play & Pause on the remote), but with the same result. 

 

I've tried 2 different remote controls, i'm able to program all functionality i need, except for Play and Pause.

 

 

flirc firmware: 2.3

flirc gui: 1.2.2

 

remotes used: Tivo (series 2) and Samsung Smart TV remote

 

any ideas?

Share this post


Link to post
Share on other sites

i'm trying to not have to use a keyboard, just a single existing remote. Flirc seemed cool that i could use an existing remote. And it's working great, mostly, right up until i fast fwd the ads, but can't stop it by pressing "Play", or using "Pause". 

Share this post


Link to post
Share on other sites

there is a problem with windows media center, I'll try and address that shortly, but I'm tied up. I believe it has something to do with the ctrl+p, the ctrl needs to be sent, and then the p. I send them simultaneously. A bit ridiculous, but it's on my list of stuff to fix.

Share this post


Link to post
Share on other sites

i'm trying to not have to use a keyboard, just a single existing remote. Flirc seemed cool that i could use an existing remote. And it's working great, mostly, right up until i fast fwd the ads, but can't stop it by pressing "Play", or using "Pause". 

I think you missed the "GUI" portion there.  

 

I was suggesting to, instead of using the WMC interface that already has the media keys where you simply select Play/Pause and press the button on your remote, that you go to the Full Keyboard layout in the Flirc GUI and try programming your keys from there and see if it works better. I was not suggesting that you use an actual keyboard.

Share this post


Link to post
Share on other sites

I actually have a similar problem.  Though mine is for the INFO button and the SKIP BACK and SKIP FWD commands.

 

Initially I couldn't program PLAY or PAUSE either like the OP and just like Deadpool suggested, programming via the "full keyboard" layout in the GUI fixed that.  Unfortunately this didn't work for my other buttons.  This makes using MediaBrowser very difficult as it doesn't seem to use the standard Rewind of Fast-Forward commands but uses Skip Back and Skip Forward.  So I essentially have no easy way to navigate when using it.

 

Is the 2.3 firmware relatively new?  I feel like I'm on 2.2 but will have to check when I get home, could this have fixed the issue?

Share this post


Link to post
Share on other sites

Play = Ctrl+Shift+P

Pause = Ctrl+P

Would you mind seeing if you can get the following commands working for you:

Skip Back = Ctrl+B

Skip Forward = Ctrl+F

Shortcut Menu = Ctrl D

Share this post


Link to post
Share on other sites

what were the shortcuts you programmed? I'd like to update the wmc controller if it makes sense.

I think one of the key ones missing:

 

The "Green Button" command = Windows Key+Alt+Enter

Live TV = Ctrl+T

Recorded TV = Ctrl+O

 

I programmed them in the Full Keyboard layout, but if you look into adding to the Windows Media keyboard those would be helpful.

Share this post


Link to post
Share on other sites

i was able to get a buttons working for:

Windows Key+Alt+Enter (mega!)

Live TV = Ctrl+T

Recorded TV = Ctrl+O

Guide = Ctrl+G

 

but not 

Skip Back = Ctrl+B

Skip Forward = Ctrl+F

Shortcut Menu = Ctrl+D

Share this post


Link to post
Share on other sites

i was able to get a buttons working for:

Windows Key+Alt+Enter (mega!)

Live TV = Ctrl+T

Recorded TV = Ctrl+O

Guide = Ctrl+G

 

but not 

Skip Back = Ctrl+B

Skip Forward = Ctrl+F

Shortcut Menu = Ctrl+D

Same exact thing for me, thanks for checking it out.

 

Jason, is there anything that can be done to fix this?

 

These are tough not to have when playing MKV files in MediaBrowser3 since the standard MCE "Rewind" and "Fast Forward" don't work and you have to use "Skip Back" or "Skip Forward."  I'd rather not rely on a separate keyboard for this.

 

The Info button is a really hard one not to have.

Share this post


Link to post
Share on other sites

How about the media keys? Do those work? They have ff and next track previous track and rewind

Wow, thanks!  Using the Media Keys keyboard got the Skip Back (Previous) and Skip Forward (Next Track) working!  Any suggestions for the Info command (Ctrl+D)?  Also known as the "Shortcut Menu" in WMC.

Share this post


Link to post
Share on other sites

I'd like to also confirm that play, stop & pause do not seem to work in media center (firmware 2.3 ui 1.2.2).

I tried the media center binding page and also the media keys binding page to no avail.

 

Fast forward, and backwards seems to work fine.

 

Setting up the those keys through the full keyboard page does work.

Edited by blah1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...