Jump to content
Flirc Forums
galante2123

Flirc, RaspBMC and Harmony Smart Control (915)

Recommended Posts

I have been through these forums all day and I feel like I am still missing something.  I connected my Flirc USB to my Windows 7 box and installed the GUI, then forced the firmware update to v2.2.  This failed once and the GUI just hung for about an hour.  I closed and finally got the firmware to update to v2.2.

 

Next I connected to myharmony.com and added the Flirc and XBMC profile and set up the activity to switch my Sony Reciver to the proper HDMI and my TV to the proper input and ofcourse use the Flirc XBMC device.  I synced and then plugged in the USB and rebooted the Raspbery Pi sporting the RaspBMC OS.  I then tried to use the remote and it would not work.

 

So then I went into the RaspBMC settings and enabled the IR Remote feature and selected the Windows MC defaults I believe.  I was hoping to see a Flirc profile to chose from but there is not one.  I rebooted the unit and got a LIRC prompt on the bottom right that said a config was created successfully.  Tried the remote again, still nothing.

 

I am stuck, not sure if I missed something or what.  I saw may mentions of the git repo for XBMC but due to it age and the dates on the commits I am not sure it is something I need or what.  Can anyone walk me through this process to matbe see where I missed a step?

Share this post


Link to post
Share on other sites

Turns out the flirc-xbmc repo was infact all I needed here. I added the src files to the .xbmc/addons section and added the udev rule as well. On the reboot of the Rasbmc the Flirc gui was started and I was good to go. I am still not sure if I actually needed to program the up, down, left, right, enter and back keys but I did. I did then load a configuration which pointed by default to a flirc config and in the end the system is up and running. Hopefully this helps someone else out in the future. Now on to the long press configurations to see if I can get these working.

Share this post


Link to post
Share on other sites

Turns out the flirc-xbmc repo was infact all I needed here. I added the src files to the .xbmc/addons section and added the udev rule as well. On the reboot of the Rasbmc the Flirc gui was started and I was good to go. I am still not sure if I actually needed to program the up, down, left, right, enter and back keys but I did. I did then load a configuration which pointed by default to a flirc config and in the end the system is up and running. Hopefully this helps someone else out in the future. Now on to the long press configurations to see if I can get these working.

thanks for posting this!

Share this post


Link to post
Share on other sites

galante2123 - I am hoping you can help me in the right direction.  I am extremely frustrated as a new user trying to get this to work on my Pi running RaspBMC.  It looks like you have experienced exactly what seems to be happening in my case. (details below)

I have been through these forums all day and I feel like I am still missing something.  I connected my Flirc USB to my Windows 7 box and installed the GUI, then forced the firmware update to v2.2.  This failed once and the GUI just hung for about an hour.  I closed and finally got the firmware to update to v2.2.

 

Next I connected to myharmony.com and added the Flirc and XBMC profile and set up the activity to switch my Sony Reciver to the proper HDMI and my TV to the proper input and ofcourse use the Flirc XBMC device.  I synced and then plugged in the USB and rebooted the Raspbery Pi sporting the RaspBMC OS.  I then tried to use the remote and it would not work.

 

So then I went into the RaspBMC settings and enabled the IR Remote feature and selected the Windows MC defaults I believe.  I was hoping to see a Flirc profile to chose from but there is not one.  I rebooted the unit and got a LIRC prompt on the bottom right that said a config was created successfully.  Tried the remote again, still nothing.

 

I am stuck, not sure if I missed something or what.  I saw may mentions of the git repo for XBMC but due to it age and the dates on the commits I am not sure it is something I need or what.  Can anyone walk me through this process to matbe see where I missed a step?

It took me most multiple tries on Windows, Linux and OSX machines to finally get a successful firmware upgrade (to 2.3 in my case.)  I too experienced the hanging you describe - in most cases not having any impact on upgrading the firmware.  I finally did get a successful upgrade to 2.3.  I too configured my Harmony remote with the Flirc device.  I also enabled  the RaspBMC settings for the IR Remote feature and selected the Windows MC defaults.  When that did not work, I tried the lirc setting.  Still no go.  I also tried the Flirc configuration add-on the allows you to program the flirc on RaspBMC.  Despite multiple tries - that utility continues to show disconnected on my Pi.   I feel like I've been banging my head against the wall trying to get my new flirc to work on RaspBMC...with no luck.  The funny thing is that I can plug the flirc into my windows laptop and it controls xbmc on that PC just fine! 

 

Turns out the flirc-xbmc repo was infact all I needed here. I added the src files to the .xbmc/addons section and added the udev rule as well. On the reboot of the Rasbmc the Flirc gui was started and I was good to go. I am still not sure if I actually needed to program the up, down, left, right, enter and back keys but I did. I did then load a configuration which pointed by default to a flirc config and in the end the system is up and running. Hopefully this helps someone else out in the future. Now on to the long press configurations to see if I can get these working.

 

 

I believe I did this.  I added http://xbmc.flirc.tv/ as a source, and installed the addons.  from what I can tell this gave me the ability to "program" the flirc via XBMC rather than having to use windows....IF the flirc was identified by my Pi.  (But when I am in the configuration interface, it just shows disconnected.)  

 

I am not sure what you mean by "added the udev rule as well."  I am wondering if that is my missing piece that is preventing the flirc from being recognized on my RaspBMC...Is that possible?   I am not sure how to add that udev rule.  Can you help me understand how to add that rule?

 

Is there anything else I should be looking at to get the flirc recognized?

 

Thanks a lot for any insight you can provide.

 

Ed

Share this post


Link to post
Share on other sites

Ed - I understand the frustration all too well trust me ;)  I completed all of my changes on the command line, so I can guide you through the changes in that manner.

 

First can you SSH into your device?  I ask because you need to check if the add-on you installed in fact installed and dropped the correct files into the proper location.  Also you will need to be able to add a udev rule to your device if you are running a Linux based machine (where the actual Flirc device will plug into).  The udev rule you need to add is made to auto mount the usb for read and write access and this is just a work around.  The udev rule is simply a file that the Linux system looks at while loaded the OS and applies the "rules" each file describes.  You can see the actual code from the github repo here: https://github.com/flirc/flirc-xbmc-plugin if you look in the folder marked linux you will see the file that has the generic udev rule you need to create.  Its one line of code:

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", MODE="0666", GROUP="pi"

You put that in a file in the /etc/edev/rules.d directory and then reboot your XMBC device and you should be all set.  You may have to reselect the Windows MC contoller, but I only say this becasue this is what is selected for mine.  This was my missing piece to get the whole thing up and running.  You will need to do this step to get your RaspBMC device to see the Flirc usb.  Once you add this on you next reboot you should see it as "connected".

 

If you installed the add-on by adding it as a source and saw the gui for the Flirc device on reboot then you may already be up and running after adding the udev rule.  Once I added the udev rule the gui popped up for me on my RaspBMC and wanted me to prgram a device as well.  I happily followed the on screen setup and programed the arrows, a back key and enter key.  This is not needed and I realized that when it then asked me to save my configuration.  If you have the add-on you do not need to physically program the device, if you can get back to that gui on your XBMC unit on the left menu you can "load a configuration"  this is what you want.  The add-on has a pre-programmed config file and when I selected the load option I was only presented with one option, once selected I closed the Flirc gui and have been good to go.

 

Let me know if this helps, or sounds "unclear".  I have been writing this as I have been working on some code between tests ;)

Share this post


Link to post
Share on other sites

Ed - I understand the frustration all too well trust me ;)  I completed all of my changes on the command line, so I can guide you through the changes in that manner.

 

First can you SSH into your device?  I ask because you need to check if the add-on you installed in fact installed and dropped the correct files into the proper location.  Also you will need to be able to add a udev rule to your device if you are running a Linux based machine (where the actual Flirc device will plug into).  The udev rule you need to add is made to auto mount the usb for read and write access and this is just a work around.  The udev rule is simply a file that the Linux system looks at while loaded the OS and applies the "rules" each file describes.  You can see the actual code from the github repo here: https://github.com/flirc/flirc-xbmc-plugin if you look in the folder marked linux you will see the file that has the generic udev rule you need to create.  Its one line of code:

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", MODE="0666", GROUP="pi"

You put that in a file in the /etc/edev/rules.d directory and then reboot your XMBC device and you should be all set.  You may have to reselect the Windows MC contoller, but I only say this becasue this is what is selected for mine.  This was my missing piece to get the whole thing up and running.  You will need to do this step to get your RaspBMC device to see the Flirc usb.  Once you add this on you next reboot you should see it as "connected".

 

If you installed the add-on by adding it as a source and saw the gui for the Flirc device on reboot then you may already be up and running after adding the udev rule.  Once I added the udev rule the gui popped up for me on my RaspBMC and wanted me to prgram a device as well.  I happily followed the on screen setup and programed the arrows, a back key and enter key.  This is not needed and I realized that when it then asked me to save my configuration.  If you have the add-on you do not need to physically program the device, if you can get back to that gui on your XBMC unit on the left menu you can "load a configuration"  this is what you want.  The add-on has a pre-programmed config file and when I selected the load option I was only presented with one option, once selected I closed the Flirc gui and have been good to go.

 

Let me know if this helps, or sounds "unclear".  I have been writing this as I have been working on some code between tests ;)

 

 

I think this makes sense, Galante2123.  Thanks a ton for writing this up.  I think you are correct in that it may become functional once I add the udev rule.   I will give it a shot when I get home from work and report back. 

 

Thanks again!

 

Ed

Share this post


Link to post
Share on other sites

REALLY Frustrated - I added the udev rule.  still no luck.  I tried multiple lengthy key presses.  Raspbmc does not want to recognize my flirc.  I am at a total loss about what to do next to get t flirc to work in my raspbmc setup.  any suggestions would be very much appreciated.  The flirc hardware works on my laptop (XBMC on Ubuntu 12.10).  No matter what i try, i cannot get it to work on my Pi.  any thoughts?  the flrc utility on my Pi continues to say disconnected.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...