Jump to content
Flirc Forums
nikotime

Flirc constantly waking up XBMC HTPC using any mapping.

Recommended Posts

EDIT: The same is happening with any mapping, not just Logitech.

 

 

I am using a Logitech Harmony and a Zotac Zbox HD-ID11 running OpenElec. 

 

Previously I custom mapped the keys with my Flirc but after seeing the latest firmware and needing to change my logitech mapping anyway I opted to use your new profile. All is working well apart from unfortunately the Flirc randomly seems to be waking my HTPC back up. Most of the time pressing power off successfully puts it to sleep (as per my XBMC settings) but sometimes it either wakes straight back up, after a few minutes or at random time intervals. I have my HTPC set to automatically sleep after 15 minutes idle but something in the new settings (occasionally!) doesn't let this happen. 

 

Any help would be much appreciated! As I see, it is periodic and I had no problems before I changed to the official logitech device in myharmony.

Share this post


Link to post
Share on other sites

Some updates on trying to get this working. It pretty much now just constantly goes through a cycle of waking up, xbmc stays on for 15 minutes then automatically suspends, x amount of time passes (from 20 seconds to however many minutes) and it then wakes up again.

 

I have played around in the bios but that has not helped. The sleep mode is S3 and wake on lan is not selected. When I disabled the setting that allows USB devices to awaken the Zbox the problem stops, but then I obviously cannot use my remote to wake it up... When my Flirc is not plugged in I can successfully suspend xbmc and it does not wake up.

 

I have also changed the USB ports that the Flirc is in but that makes no difference. 

 

XBMC log files:

 

11:46:08 T:139873758324544  NOTICE: OnSleep: Running sleep jobs
11:46:08 T:139873758324544  NOTICE: OnSleep: Stopping lirc
11:46:38 T:139873758324544  NOTICE: OnWake: Running resume jobs
11:46:38 T:139873758324544  NOTICE: OnWake: Restarting lirc
11:46:38 T:139873758324544  NOTICE: OnWake: Restarting lcd
 
Varlog:
Jan 11 11:45:24 openelec daemon.info connmand[303]: ntp: time slew -0.129677 s
Jan 11 11:46:09 openelec user.notice Boot: ### running addon sleep script /storage/.xbmc/addons/*/sleep.d/*.power (suspend)... ###
Jan 11 11:46:09 openelec user.info kernel: [56480.455989] EXT4-fs (sda1): re-mounted. Opts: data=ordered,commit=0
Jan 11 11:46:09 openelec user.info kernel: [56480.474141] EXT4-fs (sda2): re-mounted. Opts: data=ordered,commit=0
Jan 11 11:46:36 openelec user.info kernel: [56482.350437] PM: Syncing filesystems ... done.
Jan 11 11:46:36 openelec user.debug kernel: [56482.353384] PM: Preparing system for mem sleep
Jan 11 11:46:36 openelec daemon.info connmand[303]: eth0 {RX} 1359784 packets 1610835911 bytes
Jan 11 11:46:36 openelec user.warn kernel: [56482.353597] Freezing user space processes ... (elapsed 0.01 seconds) done.
Jan 11 11:46:36 openelec daemon.info connman-vpnd[469]: eth0 {update} flags 36867 <UP>
Jan 11 11:46:36 openelec daemon.info connmand[303]: eth0 {TX} 538616 packets 68520763 bytes
Jan 11 11:46:36 openelec user.warn kernel: [56482.364434] Freezing remaining freezable tasks ... (elapsed 0.01 seconds) done.
Jan 11 11:46:36 openelec daemon.info connman-vpnd[469]: eth0 {newlink} index 2 address 00:01:2E:BC:98:08 mtu 1500
Jan 11 11:46:36 openelec user.debug kernel: [56482.377743] PM: Entering mem sleep
Jan 11 11:46:36 openelec daemon.info connman-vpnd[469]: eth0 {newlink} index 2 operstate 2 <DOWN>
Jan 11 11:46:36 openelec user.warn kernel: [56482.377793] Suspending console(s) (use no_console_suspend to debug)
Jan 11 11:46:36 openelec daemon.info connman-vpnd[469]: eth0 {update} flags 102467 <UP,RUNNING,LOWER_UP>
Jan 11 11:46:36 openelec daemon.info connman-vpnd[469]: eth0 {newlink} index 2 address 00:01:2E:BC:98:08 mtu 1500
Jan 11 11:46:36 openelec daemon.info connman-vpnd[469]: eth0 {newlink} index 2 operstate 6 <UP>
Jan 11 11:46:36 openelec daemon.info connmand[303]: eth0 {update} flags 36867 <UP>
Jan 11 11:46:36 openelec user.notice kernel: [56482.378411] sd 1:0:0:0: [sdb] Synchronizing SCSI cache
Jan 11 11:46:36 openelec user.notice kernel: [56482.378672] sd 0:0:0:0: [sda] Synchronizing SCSI cache
Jan 11 11:46:36 openelec user.notice kernel: [56482.378812] sd 0:0:0:0: [sda] Stopping disk
Jan 11 11:46:36 openelec user.notice kernel: [56482.378815] sd 1:0:0:0: [sdb] Stopping disk
Jan 11 11:46:36 openelec user.info kernel: [56483.124424] PM: suspend of devices complete after 746.317 msecs
Jan 11 11:46:36 openelec user.info kernel: [56483.124429] PM: suspend devices took 0.746 seconds
Jan 11 11:46:36 openelec user.info kernel: [56483.124709] PM: late suspend of devices complete after 0.273 msecs
Jan 11 11:46:36 openelec user.info kernel: [56483.137845] pcieport 0000:00:1c.0: System wakeup enabled by ACPI
Jan 11 11:46:36 openelec user.info kernel: [56483.151217] uhci_hcd 0000:00:1d.3: System wakeup enabled by ACPI
Jan 11 11:46:36 openelec user.info kernel: [56483.151287] uhci_hcd 0000:00:1d.2: System wakeup enabled by ACPI
Jan 11 11:46:36 openelec user.info kernel: [56483.151355] uhci_hcd 0000:00:1d.1: System wakeup enabled by ACPI
Jan 11 11:46:36 openelec user.info kernel: [56483.151423] uhci_hcd 0000:00:1d.0: System wakeup enabled by ACPI
Jan 11 11:46:36 openelec user.info kernel: [56483.151591] PM: noirq suspend of devices complete after 26.876 msecs
Jan 11 11:46:36 openelec user.info kernel: [56483.151623] ACPI: Preparing to enter system sleep state S3
Jan 11 11:46:36 openelec user.info kernel: [56483.152687] PM: Saving platform NVS memory
Jan 11 11:46:36 openelec user.warn kernel: [56483.153076] Disabling non-boot CPUs ...
Jan 11 11:46:36 openelec user.info kernel: [56483.154703] smpboot: CPU 1 is now offline
Jan 11 11:46:36 openelec user.info kernel: [56483.257727] smpboot: CPU 2 is now offline
Jan 11 11:46:36 openelec user.info kernel: [56483.361040] smpboot: CPU 3 is now offline
Jan 11 11:46:36 openelec user.info kernel: [56483.361726] ACPI: Low-level resume complete
Jan 11 11:46:36 openelec user.info kernel: [56483.361726] PM: Restoring platform NVS memory
Jan 11 11:46:36 openelec user.info kernel: [56483.361726] Enabling non-boot CPUs ...
Jan 11 11:46:36 openelec user.info kernel: [56483.361726] smpboot: Booting Node 0 Processor 1 APIC 0x2
Jan 11 11:46:36 openelec user.info kernel: [56483.373530] CPU1 is up
Jan 11 11:46:36 openelec user.info kernel: [56483.373725] smpboot: Booting Node 0 Processor 2 APIC 0x1
Jan 11 11:46:36 openelec user.info kernel: [56483.385207] CPU2 is up
Jan 11 11:46:36 openelec user.info kernel: [56483.385430] smpboot: Booting Node 0 Processor 3 APIC 0x3
Jan 11 11:46:36 openelec user.info kernel: [56483.396901] CPU3 is up
Jan 11 11:46:36 openelec user.info kernel: [56483.398259] ACPI: Waking up from system sleep state S3
Jan 11 11:46:36 openelec user.info kernel: [56483.411345] uhci_hcd 0000:00:1d.0: System wakeup disabled by ACPI
Jan 11 11:46:36 openelec user.info kernel: [56483.411417] uhci_hcd 0000:00:1d.1: System wakeup disabled by ACPI
Jan 11 11:46:36 openelec user.info kernel: [56483.411487] uhci_hcd 0000:00:1d.2: System wakeup disabled by ACPI
Jan 11 11:46:36 openelec user.info kernel: [56483.411556] uhci_hcd 0000:00:1d.3: System wakeup disabled by ACPI
Jan 11 11:46:36 openelec user.info kernel: [56483.464676] PM: noirq resume of devices complete after 65.419 msecs
Jan 11 11:46:36 openelec user.info kernel: [56483.465001] PM: early resume of devices complete after 0.279 msecs
Jan 11 11:46:36 openelec user.debug kernel: [56483.465256] pci 0000:00:1e.0: setting latency timer to 64
Jan 11 11:46:36 openelec user.debug kernel: [56483.465306] ahci 0000:00:1f.2: setting latency timer to 64
Jan 11 11:46:36 openelec user.info kernel: [56483.465314] pcieport 0000:00:1c.0: System wakeup disabled by ACPI
Jan 11 11:46:36 openelec user.debug kernel: [56483.465357] snd_hda_intel 0000:00:1b.0: irq 45 for MSI/MSI-X
Jan 11 11:46:36 openelec user.debug kernel: [56483.465432] uhci_hcd 0000:00:1d.0: setting latency timer to 64
Jan 11 11:46:36 openelec user.warn kernel: [56483.465471] usb usb1: root hub lost power or was reset
Jan 11 11:46:36 openelec user.debug kernel: [56483.474557] uhci_hcd 0000:00:1d.1: setting latency timer to 64
Jan 11 11:46:36 openelec user.warn kernel: [56483.474604] usb usb2: root hub lost power or was reset
Jan 11 11:46:36 openelec user.debug kernel: [56483.474802] uhci_hcd 0000:00:1d.2: setting latency timer to 64
Jan 11 11:46:36 openelec user.warn kernel: [56483.474844] usb usb3: root hub lost power or was reset
Jan 11 11:46:36 openelec user.debug kernel: [56483.475017] uhci_hcd 0000:00:1d.3: setting latency timer to 64
Jan 11 11:46:36 openelec user.warn kernel: [56483.475062] usb usb4: root hub lost power or was reset
Jan 11 11:46:36 openelec user.info kernel: [56483.548068] r8169 0000:01:00.0 eth0: link down
Jan 11 11:46:36 openelec user.info kernel: [56483.794430] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
Jan 11 11:46:36 openelec user.info kernel: [56483.797058] ata2.00: configured for UDMA/133
Jan 11 11:46:36 openelec user.notice kernel: [56483.807846] sd 1:0:0:0: [sdb] Starting disk
Jan 11 11:46:36 openelec user.info kernel: [56483.937777] usb 4-2: reset low-speed USB device number 40 using uhci_hcd
Jan 11 11:46:36 openelec user.info kernel: [56484.324426] usb 3-1: reset full-speed USB device number 2 using uhci_hcd
Jan 11 11:46:36 openelec user.info kernel: [56485.682692] r8169 0000:01:00.0 eth0: link up
Jan 11 11:46:36 openelec user.info kernel: [56485.682704] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Jan 11 11:46:36 openelec user.info kernel: [56487.527738] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
Jan 11 11:46:36 openelec user.info kernel: [56487.528353] ata1.00: configured for UDMA/133
Jan 11 11:46:36 openelec user.notice kernel: [56487.541155] sd 0:0:0:0: [sda] Starting disk
Jan 11 11:46:36 openelec user.info kernel: [56491.035372] PM: resume of devices complete after 7570.360 msecs
Jan 11 11:46:36 openelec user.info kernel: [56491.035647] PM: resume devices took 7.570 seconds
Jan 11 11:46:36 openelec user.debug kernel: [56491.035796] PM: Finishing wakeup.
Jan 11 11:46:36 openelec user.warn kernel: [56491.035800] Restarting tasks ... done.
Jan 11 11:46:36 openelec daemon.info connmand[303]: eth0 {newlink} index 2 address 00:01:2E:BC:98:08 mtu 1500
Jan 11 11:46:36 openelec daemon.info connmand[303]: eth0 {newlink} index 2 operstate 2 <DOWN>
Jan 11 11:46:36 openelec daemon.info connmand[303]: eth0 {RX} 1359784 packets 1610835911 bytes
Jan 11 11:46:36 openelec daemon.info connmand[303]: eth0 {TX} 538616 packets 68520763 bytes
Jan 11 11:46:36 openelec daemon.info connmand[303]: eth0 {update} flags 102467 <UP,RUNNING,LOWER_UP>
Jan 11 11:46:36 openelec daemon.info connmand[303]: eth0 {newlink} index 2 address 00:01:2E:BC:98:08 mtu 1500
Jan 11 11:46:36 openelec daemon.info avahi-daemon[448]: Withdrawing address record for 192.168.1.13 on eth0.
Jan 11 11:46:36 openelec daemon.info connmand[303]: eth0 {newlink} index 2 operstate 6 <UP>
Jan 11 11:46:36 openelec daemon.info avahi-daemon[448]: Leaving mDNS multicast group on interface eth0.IPv4 with address 192.168.1.13.
Jan 11 11:46:36 openelec daemon.info avahi-daemon[448]: Interface eth0.IPv4 no longer relevant for mDNS.
Jan 11 11:46:36 openelec daemon.info connmand[303]: eth0 {del} route 0.0.0.0 gw 192.168.1.1 scope 0 <UNIVERSE>
Jan 11 11:46:36 openelec daemon.info connmand[303]: eth0 {del} route 192.168.1.1 gw 0.0.0.0 scope 253 <LINK>
Jan 11 11:46:36 openelec daemon.info connmand[303]: eth0 {del} route 0.0.0.0 gw 192.168.1.1 scope 0 <UNIVERSE>
Jan 11 11:46:36 openelec daemon.info connmand[303]: eth0 {del} address 192.168.1.13/24 label eth0
Jan 11 11:46:36 openelec daemon.info connmand[303]: eth0 {del} route 192.168.1.0 gw 0.0.0.0 scope 253 <LINK>
Jan 11 11:46:37 openelec user.info kernel: [56491.695680] EXT4-fs (sda1): re-mounted. Opts: data=ordered,commit=0
Jan 11 11:46:37 openelec user.info kernel: [56491.726640] EXT4-fs (sda2): re-mounted. Opts: data=ordered,commit=0
Jan 11 11:46:37 openelec user.notice Boot: ### running addon sleep script /storage/.xbmc/addons/*/sleep.d/*.power (resume)... ###
Jan 11 11:46:37 openelec daemon.warn connmand[303]: Skipping disconnect of carrier, network is connecting.
Jan 11 11:46:37 openelec daemon.info avahi-daemon[448]: Joining mDNS multicast group on interface eth0.IPv4 with address 192.168.1.13.
Jan 11 11:46:37 openelec daemon.info avahi-daemon[448]: New relevant interface eth0.IPv4 for mDNS.
Jan 11 11:46:37 openelec daemon.info avahi-daemon[448]: Registering new address record for 192.168.1.13 on eth0.IPv4.
Jan 11 11:46:37 openelec daemon.info connmand[303]: eth0 {add} route ff00:: gw :: scope 0 <UNIVERSE>
Jan 11 11:46:37 openelec daemon.info connmand[303]: eth0 {add} route fe80:: gw :: scope 0 <UNIVERSE>
Jan 11 11:46:37 openelec daemon.info connmand[303]: eth0 {add} address 192.168.1.13/24 label eth0 family 2
Jan 11 11:46:37 openelec daemon.info connmand[303]: eth0 {add} route 192.168.1.0 gw 0.0.0.0 scope 253 <LINK>
Jan 11 11:46:37 openelec daemon.info connmand[303]: eth0 {add} route 192.168.1.1 gw 0.0.0.0 scope 253 <LINK>
Jan 11 11:46:37 openelec daemon.info connmand[303]: eth0 {add} route 0.0.0.0 gw 192.168.1.1 scope 0 <UNIVERSE>
Jan 11 11:46:37 openelec daemon.info connmand[303]: eth0 {add} route 0.0.0.0 gw 192.168.1.1 scope 0 <UNIVERSE>
Jan 11 11:46:37 openelec daemon.info connmand[303]: eth0 {del} route fe80:: gw :: scope 0 <UNIVERSE>
Jan 11 11:46:37 openelec daemon.info connmand[303]: eth0 {del} route ff00:: gw :: scope 0 <UNIVERSE>
Jan 11 11:46:37 openelec daemon.info connmand[303]: ntp: time slew +0.662415 s

 

 

 

Additional log files in pastebin: http://pastebin.com/sdYFa2aa

Share this post


Link to post
Share on other sites

I'm experiencing the same thing..i just upgraded to firmware 2.2 and Flirc v1.1.6 and still happens.   After suspending the HTPC (intel NUC) just keeps waking randomly.  Any help?

Share this post


Link to post
Share on other sites

I've just updated to the 15th Jan firmware which didn't work with the Logitech mapping (I'm unsure why) so I manually mapped all the keys and still the flirt wakes up my box.

Share this post


Link to post
Share on other sites

Nikotime I got it working with my openelec system. Update the GUI (1.1.7) and firmware to the latest version from a few days ago. Basically I had to enable "detect sleep" function in the advanced section on the GUI. Then I mapped a key to the wake command. I now use the wake button to turn on my machine and a seperate button to shutdown (suspend) my machine. I no longer have any random wake ups. I suspect it has to do with this detect sleep function. Give it a try.

Share this post


Link to post
Share on other sites

I've got this problem also with openelec and have set the above setting and mapped a wake button but it still wakes itself. I tested last night, set it to resume and when I checked in the morning it was awake. :(

Share this post


Link to post
Share on other sites

do you guys have sleep detect enabled in the GUI?

 

Also, make sure you haven't recorded any noise. use the commandline, flirc_util settings. Look for duplicates. Delete all duplicates and re-record those keys.

When receiving a signal, flirc will send a character to the machine. Regardless of the state of the machine. Sleep detect tells flirc to check if the computer is sleeping. If it is sleeping, do not send any keys unless it's the 'wake-up' command.

Further, if you don't have sleep detect, and have recorded erroneous noise, then the machine will see noise as a false signal, and send a command to the computer.

 

** EDIT **

 

TLDR; enable sleep detect in the gui

Share this post


Link to post
Share on other sites

Mines sorted. I did tick the sleep detection box but when I checked after it wasn't so I re enabled it and that fixed my problem.

Share this post


Link to post
Share on other sites

Just a follow up question, I'm having the same issue and I have:

FLIRC USB (2nd Generation) Universal Remote Control Receiver for Media Centers and Set Top Boxes

 

I have the latest firmware and when I go into Advanced menu, my sleep options are "GREYED OUT" and not available to choose. Please help. I'm now having the FLIRC turn on my Media PC with any button press or activity from my Harmony Hub/Remote.


Thanks in advance!

Edited by bunnychow

Share this post


Link to post
Share on other sites
3 hours ago, bunnychow said:

Just a follow up question, I'm having the same issue and I have:

FLIRC USB (2nd Generation) Universal Remote Control Receiver for Media Centers and Set Top Boxes

 

I have the latest firmware and when I go into Advanced menu, my sleep options are "GREYED OUT" and not available to choose. Please help. I'm now having the FLIRC turn on my Media PC with any button press or activity from my Harmony Hub/Remote.


Thanks in advance!

Can you elaborate, what's the issue you are having?

Share this post


Link to post
Share on other sites
4 hours ago, jason said:

Can you elaborate, what's the issue you are having?

Thanks for the reply! Basically same as the original post:

1. I have a Kodi on PC, Harmony Hub, Harmony Remote, and Flirc plugged into PC.

2. Now any button press on the Remote, sends a wake up to PC. Even the Watch TV button which is programmed to turn on TV and Receiver WILL WAKE the PC.

This didn't happen before the upgrade. 

Thanks,

danO

Share this post


Link to post
Share on other sites
5 minutes ago, bunnychow said:

Thanks for the reply! Basically same as the original post:

1. I have a Kodi on PC, Harmony Hub, Harmony Remote, and Flirc plugged into PC.

2. Now any button press on the Remote, sends a wake up to PC. Even the Watch TV button which is programmed to turn on TV and Receiver WILL WAKE the PC.

This didn't happen before the upgrade. 

Thanks,

danO

before what upgrade?

Share this post


Link to post
Share on other sites

Sorry, you're feeding me bits of information. Could have been the device upgrade too. Do you remember when this happened? When did you get it, when did you do the upgrade?

If you put flirc into a computer, open up wordpad, textpad, then press the activity button on your remote, are any keys sent to the pc?

Can you describe the activity a bit?

Did you use my software to pair your flirc with your logitech remote? If you did, you don't need to, since the keys are built in. If you go to file->advanced, you'll see there are a bunch of built in profiles.

It's possible that something in your activity is in the built in rom table, or a recorded key.

Flirc wont wake up the machine if a signal is received that's not recorded.

Share this post


Link to post
Share on other sites
23 hours ago, jason said:

Sorry, you're feeding me bits of information. Could have been the device upgrade too. Do you remember when this happened? When did you get it, when did you do the upgrade?

If you put flirc into a computer, open up wordpad, textpad, then press the activity button on your remote, are any keys sent to the pc?

Can you describe the activity a bit?

Did you use my software to pair your flirc with your logitech remote? If you did, you don't need to, since the keys are built in. If you go to file->advanced, you'll see there are a bunch of built in profiles.

It's possible that something in your activity is in the built in rom table, or a recorded key.

Flirc wont wake up the machine if a signal is received that's not recorded.

It's all good. Since I knew it worked before I upgraded firmware (although it could be any combination of Logitech stuff, etc.) I basically nuked everything from the Flirc install, Harmony install, as well as all the programmed remote settings.

I reinstalled everything, upgraded all the firmware, updated all logitech software, and then re-customized remotes/activities. All good now! Thanks! I didn't want to spend time debugging each element to figure out what broke what! It's back to normal now. Thanks again!

Edited by bunnychow

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×