Jump to content
Flirc Forums

Every second keypress not working (more or less)


adahmen
 Share

Recommended Posts

Hello,

 

I try to control my Dreambox (Linux based SAT receiver with Enigma) with FLIRC and my Harmony ONE.

 

But I have an annoying effect: If I press a button on my ONE once, it's fine ... if I press the same button a second time, nothing happens ... and if I press the same button a third time it's again fine (and I can repeat as long as I could). 

Every second click is not working.

 

If I use different buttons it's working sometimes ... but more or less every second click is also not working.

 

Any idea why this is happining and how can I change this behaviour. With this setup I'm not able to control my Dreambox.

 

 

By default, the Dreambox can be controlled by a keyboard and FLIRC is recognized well. 

 

Best regards,

Albert

Link to comment
Share on other sites

Any idea why this is happining and how can I change this behaviour.

 

Likely due to the remote alternating between two different remote strings. I forget but it's something to do with detecting people walking in front of the line of sight.

 

Anyway, the solution is simple; record the other key too.

 

e.g. using the gui record enter (it will say key recorded), press to record enter again and press the same key on your remote to record again (hopefully catching the 2nd press code).

 

Does this make sense?

Link to comment
Share on other sites

  • 1 month later...

I'm a new (and happy, great product) Flirc user. I have the same/similar issue as mentioned above. I need to learn all keys twice (with no one walking between mee and the Flirc sensor). When doing this everything works fine, Upon first teach the button works once, next time doesn't, third time does. I am sending codes between RC5 code 0 0 and RC5 0 30 (can supply hex if needed). This is tested with software "Flirc Setup.exe [ v1.2.2 ]". on Windows Vista x64, USB 2.0

Link to comment
Share on other sites

  • 5 months later...
  • 6 years later...

I'm an old user, having happily installed Flirc with the 1.0 firmware on my Raspberry box running Openelec...

Recently, noise creating phantom-keypresses lead me to a thread where it suggested updating the firmware, which now provides a noise control.

I did it, but I couldnt check yet if the noise issue is gone, because now it appeared the one-keypress-every-two issue. It certainly is firmware related, because nothing else changed.
I tried the procedure to record twice every key, but it didnt solve the issue.

For additional info, I attached the output of flirc-util settings

flirc-settings.txt

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...