Jump to content
Flirc Forums

[Mac] Programming software crashes on launch after update from 3.25.3 to 3.26.0


Cubytus
 Share

Recommended Posts

Hi there,

I wanted to give another chance to the Flirc IR receiver and fired up Flirc's software. I was running 3.25.3 and received an alert for an update to 3.26.0, which I installed. For sure it immediately crashes on launch.

Platform: Mac OS X 10.14.6

Why is the software acting up *again*?

Link to comment
Share on other sites

Sorry, I was hoping to connect over a remote debugging session. Can you post the output of the following. Run this in a terminal, hopefully it gives me a clue as to what's going on:

 DEBUG=true /Applications/Flirc.app/Contents/MacOS/Flirc 

Link to comment
Share on other sites

Terminal output:

$ DEBUG=true /Applications/Flirc.app/Contents/MacOS/Flirc
dyld: Library not loaded: @executable_path/../Frameworks/libusb-1.0.0.dylib
  Referenced from: /Applications/Flirc.app/Contents/MacOS/Flirc
  Reason: no suitable image found.  Did find:
    /Applications/Flirc.app/Contents/MacOS/../Frameworks/libusb-1.0.0.dylib: cannot load 'libusb-1.0.0.dylib' (load command 0x80000034 is unknown)
    /Applications/Flirc.app/Contents/MacOS/../Frameworks/libusb-1.0.0.dylib: stat() failed with errno=1
    /Applications/Flirc.app/Contents/MacOS/../Frameworks/libusb-1.0.0.dylib: cannot load 'libusb-1.0.0.dylib' (load command 0x80000034 is unknown)
    /Applications/Flirc.app/Contents/MacOS/../Frameworks/libusb-1.0.0.dylib: stat() failed with errno=1
Abort trap: 6

What timezone are you in? GMT-7?

Link to comment
Share on other sites

1 minute ago, Cubytus said:

What timezone are you in? GMT-7?

Yes

It's gotta be related to the version of the OS. I'm not quite certain the cause yet, all I did was figure out how to sign the app.

** edit** I got an older mac I can't upgrade, I just reproduced it. Give me a day or two. I'll figure it out. I'm really sorry for the inconvenience. 

Here is the old one: https://flirc.tv/software/flirc-usb/GUI/release/mac/Flirc-3.25.3.dmg

 

Link to comment
Share on other sites

OK I get it, the software can't be possibly tested on all OS versions. Why not offer older versions on the support page, in case something breaks, and give instructions to *ignore updates alerts*? Say, a list of legacy versions and matching maximum OS version?

3.25.3 appears to work on Mac OS X 10.13.6 and 10.14.6, but the "Advanced settings" is just a blank box when no receiver is connected2071991899_CapturadePantalla2022-04-02ala(s)02_54_38.png.ee05826c2248a3f11fce861e353a2c17.png

Link to comment
Share on other sites

I will add old versions to the website.

There is a lot of crud in this. I haven’t put an ounce of effort into it over three years. 

I’ve been working on a universal remote. The software is no comparison. Once it launches, Flirc’s interface will be rewritten in this technology and built on the work I’ve done. 

Link to comment
Share on other sites

Sure I'll come back on the website from time to time to see when it appears, hoping Flirc software will finally be stable. There are still plenty MacBook Pro pre-Retina in service that can't upgrade past Catalina, and some may even stop at Mojave because of compatibility issues with still-32bit apps (my case).

Plenty of competition, I currently use either a keyboard or the official software remote for Kodi, none of which are ideal. The first one because it's a bit large and fragile, the other because I have to look to know where I'm pressing. I hope yours will match your own Kodi-themed case and be sturdier than low quality plastic ones.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...