Jump to content
Flirc Forums

Raspberry Pi - RaspBMC - Dish Remote


Recommended Posts

Although the focus of this post is narrow, I figure it may help someone out.

 

I have a Dish remote (6.3 IR/UHF PRO) and found that when using the VCR mode button, the Sony DVD code 617 worked the best with XBMC on Raspbian (RaspBMC - version June 2013).  The only quirk I found was that the left direction button doesn't work.  Its not that major of an annoyance, but perhaps after enjoying my flirc for a few days I'll see if I can resolve the issue.

 

Thanks to Jason and the rest of the team for developing such a great product.

  • Like 2
Link to post
Share on other sites
  • 2 weeks later...

I have a 6.2 IR/UHF PRO from Bell TV and after trying code 667 found major keys missing like all the arrows and surrounding buttons which made it useless I figure it was close enough to you 6.3 that the codes should be about the same but if they are you must not use those buttons.

 

The sat mode is hard coded to UHF so it was useless even though all keys work (I don't use Bell anymore and got the remote out of a box)

Finally I figured out the perfect code that has every button work. I programmed AUX to think it was controlling a second SAT receiver on a different channel and it used IR.

 

Programming was a little different then normal vcr codes since it only requires what channel you want it on.

 

hold AUX until all buttons light up

press 3

press a IR channel number (I used "4")

press #

press "record"

Link to post
Share on other sites

shadowofdarkness,

 

Thanks for that new code. I tried it and see all the buttons on the remote are active (lighting up). Unfortunately, when I try to program the buttons in flirc, the GUI keeps indicating that the buttons/keys already exist even though I've cleared the configuration. It appears the IR codes seem to overlap or flirc can't quite distinguish between them. Did this happen to you at all?

 

FYI, I'm using the latest GUI/firmware here...

GUI - v1.0.0-rc.1

CLI  - v1.0.6

FW  - v1.1.0-rc.1

Link to post
Share on other sites

I had that problem with any code using beta firmware, in the end I downgraded to the last stable (fw_1.0 and Linux gui 0.96) and I have no problems now.

 

I tried that too and can't get it to work. The difference may be that I am trying to get a different remote (for the 6131 PVR) working first before trying it on the UHF/IR remote. I have 2 6131 IR remotes and 1 IR/UHF remote and I'd prefer to get it working on all three the same way so that the interface is consistent. Oh well, I'm stuck with code 667 for a while.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...