Jump to content
Flirc Forums
zaphodFlirc

One Remote press, continued repeating Flirc commands

Recommended Posts

not quite sure what u mean by get stuck? With noise cancel on? Or the repeating keys?

Edit. I tried setting inter key delay 0 with noise cancelling, that didnt work very good. Also tried inter key delay 0 without noise cancel, which was even worse than inter key delay 5. So I tried setting inter key delay 7 with noise cancell off, and so far its been great. I hope it behaves now ;) By the way, whats new in firmware 3.7? Cant seem to find any patchnotes/changes anywhere?

Edited by nixpix

Share this post


Link to post
Share on other sites

I've been having the double press problem for months now and it's driving everyone mad!

Setup

Harmony 350 with default Flirc/Kodi profile.
3 more buttons programmed and added to keyboard.xml 
Fire TV
Kodi

Issue

Only seems to happens with the back button which I believe maps to browser_back in the default harmony/flirc/kodi setup
Also replicate-able when the Flirc is plugged into my PC without Kodi - using multiple tabs in Notepad++ the back button cycles tabs twice on a single press.
If you tap the button VERY quick, the problem doesn't occur on either PC & N++ or FireTV & Kodi.

Things tried

Set the key delay in Flirc to both 0 and 7. 
Set Harmony repeat value to 0.
Re-installed Kodi 16 and 17.
Re-configured the Harmony
Upgraded Flirc Firmware
 

Edited by slikvik

Share this post


Link to post
Share on other sites

Do we have any news on this at all?? It's driving me made and makes using Kodi (which is my main living room PVR) a frustrating experience.

I've tried all combinations and currently have Flirc at 7 and Harmony at 0. It's NOT Kodi on the Fire TV as it also does it on Windows outside of Kodi.

Share this post


Link to post
Share on other sites

which harmony do you have? And which flirc version do you have?

 

Share this post


Link to post
Share on other sites

Hi There. Here I am again after 3 years. Reason it took so long is I gave up on using the Pi as a media centre back then but I returned to using it right now for the simple reason that they changed the TV signal to DVBT2 in my country and now I have very bad reception. So I took my Pi and Flirc out of the drawer and configured it to used ZattooBox over LibreElec.

So what happened is I first used my TV receiver remote by Phillips to control Kodi via Flirc. No problem whatsoever. But then I got rid of that receiver, so I decided to use my old Apple remote and that's where the trouble came back: endless, chaotic key repeats. Interestingly, the very first day, it worked like a charm. The problem only appeared on the second day and lingered on until now.

I tried the trick with the grounding cable as suggested in this thread:
http://forum.flirc.tv/index.php?/topic/1202-potential-fix-for-repeating-keys/
...but that didn't change a thing.

I'm using a 1st gen Flirc (transparent enclosure) with latest Firmware version, a Pi version B and a 1st gen (white) Apple remote.

Share this post


Link to post
Share on other sites

Very frustrating for us at home as Kodi with PVR backend is my living room primary TV service. This problem only occurs on the back button but that button is used all the time so we're constantly having to give the button the quickest tap possible to stop it duplicating the key press and exiting kodi completely!

Actually I don't know if that helps in solving the problem but I can "fix" it by pressing the back button as quickly as possible. If you press it at a comfortable speed I get two instances of [browser_back].

Share this post


Link to post
Share on other sites

I have an update:

I can say that it's definitely that damned crApple remote. I don't know what it does but it's the only remote that causes such a stir. Just purchased a Minix remote and it works like a charm.

Sorry for not trying other remotes earlier – the thing is: I hardly have any and the few I have lack directional buttons so I didn't bother trying them out.

So there's that. Maybe it helps someone. The same Apple remote works fine with Apple products btw.

Share this post


Link to post
Share on other sites

Ok, so I have a Harmony 300 remote. The MyHarmony software doesn't give me any options to change key repeats/delays for that model.

And when I fire up the Flirc software v 3.0.22, the advanced settings don't give me any option there either. So what do I need to do?

Thanks.

Share this post


Link to post
Share on other sites
1 hour ago, ianevans said:

Ok, so I have a Harmony 300 remote. The MyHarmony software doesn't give me any options to change key repeats/delays for that model.

And when I fire up the Flirc software v 3.0.22, the advanced settings don't give me any option there either. So what do I need to do?

Thanks.

Can you post a screenshot?

Share this post


Link to post
Share on other sites

Okay, after going to File-Advanced Settings, I did a screen capture. I'll also upload my config. Some of the button seem to behave but a few like the arrows, really go crazy and send about three commands. I've attached my config in case that's the issue. buster is my htpc.

flirc advanced.png

my_flirc_config_for_buster.fcfg

Share this post


Link to post
Share on other sites
On 10/4/2017 at 11:46 AM, ianevans said:

Okay, after going to File-Advanced Settings, I did a screen capture. I'll also upload my config. Some of the button seem to behave but a few like the arrows, really go crazy and send about three commands. I've attached my config in case that's the issue. buster is my htpc.

flirc advanced.png

my_flirc_config_for_buster.fcfg

Uncheck the built-in profiles, let me know if that does anything. Also, what version of firmware are you on?

Share this post


Link to post
Share on other sites

I'm having the same problem here now. Was using XBMC 13.2 and did not have the issue (or had it resolved there at least), but upgraded recently to Kodi 17.3 and the problem (re)occurred. I'm using a Harmony One remote set to emulate a Syabas PopcornHour C-200 device. Target computer is a Win 7 HomePremium laptop. Flirc firmware is 3.6.

Noise-Canceller is turned off, Inter-Key delay is set to 2, built-in profiles are enabled, sequence modifiers are disabled.

Let me know if there is any more information I can provide to assist with resolving the problem.

my_flirc_config.fcfg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×