Jump to content
Flirc Forums
zaphodFlirc

One Remote press, continued repeating Flirc commands

Recommended Posts

etronic    0

I have a Harmony One RC and I'm getting occasional stuck auto-repeat,  just wondering where this is controlled from?

is it on the FLIRC device or my Linux config?

 

 

You're in the same situation as me. Harmony One and I'm getting "repeat madness" from time to time on my Pi and Raspbmc. It looks like single key press triggers it more. When you hold remore button for two or more repeats and release it it never gets stuck in loop.

Share this post


Link to post
Share on other sites
jason    141

I've got to get to the bottom of this.


Can you post pictures of your harmony settings? Advanced timing settings. Also, which remote control is it? The XBMC-Flirc profile?

Post your configuration details too.

 

** EDIT **

I mean attach your flirc.fcfg file

Share this post


Link to post
Share on other sites
Ptrax    1

I'm using the older Logitech Remote s/w to config my remote ie I haven't yet migrated to MyHarmony website yet, so not sure which screen/setting your looking for...

also where is thie flirc.fcfg is that some sort of export file? I've attached it.

my_flirc_config.fcfg

Share this post


Link to post
Share on other sites
zaphodFlirc    3

So I've now tried two things based on feedback above:

* [@STEVELEA tip] took out my USB extension cable and put the Flirc directly in the RasbPi (I now have the USB memory stick on the extension or it won't fit)

* [@COBELS tip] did the troubleshooter in the Harmony software and put the value to 1 (it was on 3 or 4 - can't remember)

 

And it SEEMS that it is now working without the horrendous repeats. I'll give it a few more tries and post back.

 

[post 3 hours later: seems stable still after removing the USB extension + turning the "to much to little value" down to 1. Will this finally be the resolution after months and months of annoyance? I really do hope so!]

Share this post


Link to post
Share on other sites
jason    141

can you guys post screen shots of these. I don't know what you are referring too. I need to repeat the setup.

Share this post


Link to post
Share on other sites
jason    141

I'm using the older Logitech Remote s/w to config my remote ie I haven't yet migrated to MyHarmony website yet, so not sure which screen/setting your looking for...

also where is thie flirc.fcfg is that some sort of export file? I've attached it.

The configuration on your flirc is definitely broken.

Upload the attached, and then try recording your keys again. I bet that fixes it.

Share this post


Link to post
Share on other sites
Ptrax    1

The configuration on your flirc is definitely broken.

Upload the attached, and then try recording your keys again. I bet that fixes it.

ok I'll try and do config from windows and then re-plug into Linux box right?

but attached a screen shot of RC config page.

ie I use the Trouble shoot button then select device and then "Responds to some commands either too many times or occasionally.

post-96-0-41739900-1385260007_thumb.png

Share this post


Link to post
Share on other sites
jason    141

ok I'll try and do config from windows and then re-plug into Linux box right?

but attached a screen shot of RC config page.

ie I use the Trouble shoot button then select device and then "Responds to some commands either too many times or occasionally.

What's the remote control? I know it's a harmony, but what's the profile? Samsung? Panasonic? Flirc? Something else?

Share this post


Link to post
Share on other sites
zaphodFlirc    3

It really looks like it has been resolved for me. Now a few days later, and I don't think I've had even one single repeat. And I haven't heard the kids complain about it either  :)

 

What did it for me (I really advise you to try this as well) was:

* [@STEVELEA tip] took out my USB extension cable and put the Flirc directly in the RasbPi (I now have the USB memory stick on the extension or it won't fit)

* [@COBELS tip] did the troubleshooter in the Harmony software and put the value to 1 (it was on 3 or 4 - can't remember)

 

STEVELEA and COBELS are now officially my heroes. Thanks guys (assuming you're guys that is...)

  • Like 1

Share this post


Link to post
Share on other sites
dantist    0

Neither Stevelea nor Cobels tips solved the problem for me.

 

I just downloaded the latest GUI to update the firmware. When I chose "Force FW upgrade" it says my flirc already has the latest one (3.1). But I haven't updated since a year or so. Is this done automatically as soon as you connect the device and start the GUI?

 

I also selected "Noise Canceler" in the settings, because that sounded like it could address the issue. But the behavior is the same: When I press the button to skip a few seconds of a movie, it goes crazy every now and then and keeps skipping 3-4 times per seconds until I press another button or disconnect flirc.

 

tail -f /storage/.xbmc/temp/xbmc.log

 

shows that they XBMC recognizes the key press 12-14 times second

17:45:07 T:3058148128   DEBUG: OnKey: right (0xf083) pressed, action is StepForward

Very frustrating.

Share this post


Link to post
Share on other sites
GoodOmens    1

Ok so the Harmony 900 sends RF signals to a base unit that converts the RF into IR signals.  The base unit then sends the IR signals out via the mini IR blasters (IR senders).  You place the blasters in front of your Home Theatre (HT) equipment so that your remote can control multiple devices. 

 

I had my home theatre equipment (XBMC box, DVR and Apple TV) all in the same cabinet, each with their own harmony mini-blaster.

The harmony sends the IR signals to ALL of the mini-blasters at the same time.  eg. If I wanted to play a movie on XBMC I'd press "play" on my remote and the harmony would send the IR signal to all of the mini-blasters BUT only the XBMC would react to the play signal because the other devices (DVR and Apple TV) wouldn't recognise the IR signal being sent).

 

The problem for me was because the IR signal is sent to all three mini blasters the FLIRC was picking up the 3 IR signals at the same time causing it to go crazy.  I had to move the flirc to a position where it would only pick up the signal from one IR blaster (not all three).  I did this by moving my XBMC/FLIRC and one IR blaster outside of the cabinet away from the other 2 IR blasters.  This solved my problem instantly.

 

Hope that makes sense.

 

Jeremy.

You can in settings tell the rf receiver to assign a port to a specific device.

Share this post


Link to post
Share on other sites
jason    141

I've been following this thread religiously and there are two problems that can happen and the multiple people posting are either experiencing one or the other.
 
Flirc is essentially a keyboard, so consider 
 
Problem
 
1) When you hit a key on the remote, one key is received on your machine, there is a delay, and then several keys are seen. Like if you had a keyboard and just pressed and held the button down.
 
2) When you hit a key, several keys are received rapidly.
 
These are two very different problems and users aren't distinguishing them here, and rightfully so, as the problem statement is too many keys are received. 
 
So let's talk about the solutions we've figured out.
 
1a) If you have a harmony remote, lower the repeat value in the harmony software: in the remote, go to the troubleshooter and lower the value to 0 or 1
1b) if you don't, lower the interkey_delay in the flirc advanced software.
 
2a) raise the interkey_delay in the flirc advanced software
 
I think there is one more cause for 2, but I haven't determined what it is yet, I'm still working on it. It's going to require some special firmware that I started on.
 
I'll put a sticky at the top of this thread for others, this seems to be the solution. [edit by Chris: A separate sticky has been made to make the issue easier to find for those who may be experiencing it. Continue to discus it here though]

Share this post


Link to post
Share on other sites
dantist    0

> 1a) If you have a harmony remote, lower the repeat value in the harmony software: in the remote, go to the troubleshooter and lower the value to 0 or 1

The value was set to 1, I changed it to 0. If anything, this made the problem worse.

 

> 2a) raise the interkey_delay in the flirc advanced software

The value was already set to 6, which is the maximum.

 

To be honest, I doubt that these settings are targeting the root cause of the problem. It would make sense that a higher delay / lower repeat value helps with double key presses, but the problem here is that one physical key press triggers infinite key presses in the software.

 

Maybe it's not even a bug in your firmware but in the RPi service that handles the messages that are sent via flirc? But then I don't understand why a Logitech K400 is working flawlessly.

Edited by dantist

Share this post


Link to post
Share on other sites
dantist    0

Update: I set the repeat value in the Harmony remote flirc-profile to "2", which greatly improved the issue. I only had a few double/endless repeats within the last five days.

Edited by dantist

Share this post


Link to post
Share on other sites
Din    2

Prior to the arrival of my FLIRC and Xbox one media remote I'd been using the official XBMC Android remote application to control both XBMC on an Ubuntu / Win PC and also OpenElec on a Raspberry Pi and a Cubox-i.

 

I too had the endless repeat problem on the PC, Pi and Cubox-i. That was until I selected the 'Send Single Keypress' option in the application's settings. Thereafter everything has been smooth and error free. With only the slight inconvenience of thumb ache while navigating the occasional long list or large media library.

 

I had hoped that my new remote would seamlessly replace the smartphone - it's a pain having to boot up a phone every time you want to play a video / track - but I was disappointed to re-encounter the same problem with endless repeats. Though this time without an obvious solution: I've tried every inter key delay, and selecting and deselecting all the advanced options but find the remote is still almost completely unusable.

 

The application solution and the problems others have encountered suggest to me that perhaps the problem is with the Kodi/XBMC software and not the FLIRC firmware. And that until the root cause is remedied it might be an idea to circumvent the annoyance by adding a 'Send Single Keypress' option to FLIRC's settings. That's if it's technically possible. And not too much work.

 

Thanks for your time and hope this helps.

 

Thomas

Edited by Din

Share this post


Link to post
Share on other sites
Din    2

Please ignore my whinge above. I discovered a solution to my double keypress issue when I accidentally held the Xbox One Media remote back to front. If I point the remote directly at the FLIRC then I get the usual over enthusiastic response. But if instead I point the remote 180 deg or 90 deg to either side then everything works just fine. As it does with my preferred option of obscuring the Cubox-i & FLIRC behind the TV with the FLIRC 180 deg to the remote. I am now very happy with both the remote and FLIRC. And a little embarrassed about the previous post.

 

Is the problem that FLIRC is just too potent for its own good?

Edited by Din

Share this post


Link to post
Share on other sites
jason    141

I like that word, potent.

 

Yes, super sensitive. May help to re-pair you remote and point it away from flirc.

Share this post


Link to post
Share on other sites
Din    2

I'm using the 3.5 firmware. But by an astonishing co-incidence just as I finished typing the last sentence an Ubuntu update notification told me that I could update to 3.6. I've done just that and everything is still tickety-boo.

Share this post


Link to post
Share on other sites
jason    141

Yeah, I forgot I updated my manufacturing line to use a newer firmware for new devices and those started shipping. Latest GUI's didn't support those, so I had to quickly release an update. Oops. Slaps forehead.

  • Like 2

Share this post


Link to post
Share on other sites
wsmeyer    0

I'm now experiencing this.

 

For over a year my setup worked perfectly:

  intel i3 NUC

  Windows 7 Pro always kept up to date

  Only software installed - Plex Home Theater, Firefox, flirc

  XBOX One Media Remote ( http://ecx.images-amazon.com/images/I/61Pwgq%2B8xeL._SL1300_.jpg )

 

 

Last Friday I purchsed the newer 5th gen i5 NUC, installed the same W7 Pro, let it do all it's updates, PHT, Firefox, flirc, and of course now, just randomly when I press a key it goes berzerk as if I'm holding down the key.

 

I DID NOT reprogram or do anything to the flirc so I'm really not sure what is different between the old and new setup that could cause this. I have seen people mentioning power supplies. The new NUC has a different power supply so when I get home I'll check if the old and new are the same voltage and if so try the olde one.

 

 

 

Share this post


Link to post
Share on other sites
wsmeyer    0

Changing the power supply completely solved my problem. I am quite happy that it is again working perfectly.

 

The problem is completely reproduceable / fixed by swappinmg the new / old power supplies. The older i3 NUC came with a two piece power supply. 3 prong power cord plugging into a brick with a cable then plugging into the NUC. The newer i5 came with a much smaller 2 prong one piece unit, usually referred to as a "wall wart". Both 19VDC 3.42A.

Share this post


Link to post
Share on other sites
nixpix    0

I am also experiencing this issue. I've had my flirc 2 weeks and it mostly working great, with the one exception of sometimes repeating keys endlessly. What happens is what many others here reported - pressing one key once on the remote and flirc outputting command endlessly, it keeps sending presses inifinitely until another key is pressed on the remote.

The remote is not a Logitech harmony though, as many others have, its a remote originally shipped with a Dune HD Smart B1 mediastreamer. Firmware is 3.6 with inter key delay 5. I have checked that the remote does not send repeating keys. I have also tried the noise cancelling option, and it does seem to help, but then instead the remote reacts extremely sluggish and has a delay between accepting presses, like press one key then wait 1-2sec and then press again.

I am using flirc on an Asus chromebox with Kodi 15.2/openELECT 6.0 fritsch EGL build.

Share this post


Link to post
Share on other sites
jason    141

Definitely try changing the interkey delay settings, it shouldn't get stuck. How often does this happen?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×