Jump to content
Flirc Forums
zaphodFlirc

One Remote press, continued repeating Flirc commands

Recommended Posts

unfortunately this did not help. Here's what I did:

* Used Plex on the HarmonyOne as per rtessenaer's suggestion

* upgraded UI & Firmware as per Jason's suggestion

 

I now get double clicks each time. No longer dozens and dozens, but quite consistently 2 presses. I also tried the inter-keypress delay of 100ms, but that didn't resolve either.

 

Hope to hear others' experiences!

Share this post


Link to post
Share on other sites

Can you post your flirc configuration?

I'm trying to reproduce this, I can't... I'm pretty annoyed because I'm sure I can fix it pretty easily. 

This doesn't happen on the original firmware, correct?

 

Here is another thread on the topic: 

Share this post


Link to post
Share on other sites

Try a keypress delay of 400ms or higher.  I also found I got glitches when the line of sight between my Harmony and the Flirc was interrupted.   I ended up using a USB extension cable to move the Flirc to the front of my entertainment unit.

 

I also tried the inter-ketypress delay of 100ms, but that didn't resolve either.

Share this post


Link to post
Share on other sites

@JAC, the 400 does not work either though thanks for the suggestion. As for the cable, I've always had my Flirc on an extension cable.

 

@Jason, attached the config I just tried again. This config was made using the Minimalist config automation in the Flirc tool on Windows7. With the latest firmware and UI. I also did this is a pitch black room since I read somewhere some theories about IR interference. I really hope you get to the bottom of this since it's very annoying that I can't use the harmony with the Flirc!

 

Uhm, how do I attach my config? Will post this message and see if there's another way I need to attach my config...

Share this post


Link to post
Share on other sites

Can you post your flirc configuration?

I'm trying to reproduce this, I can't... I'm pretty annoyed because I'm sure I can fix it pretty easily. 

This doesn't happen on the original firmware, correct?

 

hoping to find a way to add an attachment to this post. First let me respond to your question: I've had this Harmony problems for quite a while now. Have tried 2 new firmwares hoping for resolution, but still repeating behaviour. So it HAS happened on the original firmware (and the beta following that, and now the latest).

 

Ah! Found where to add an attachment! here it is then!

MarkJonkers_flirc_config.fcfg

Share this post


Link to post
Share on other sites

If this happened on the original firmware, something else is wrong. Let's get you a replacement, shoot me an email. http://flirc.tv/support/

 

I'd also like to take a look at this one. Your config looks perfectly fine, like everything is operating correctly.

Share this post


Link to post
Share on other sites

@nooryani84: many thank for the tip. Tried that. Put the delay first to 100, no avail. Then upped to 800, also kept repeating. Not 100% sure that the Rpi is actually using the advanced settings file... Any way I can check that the setting is actually 'implemented'?

 

So here's the current behavior:

* the 'enter' key does a double keypress (haven't yet caught it doing many more. Just twice)

* when I'm in the main screen, left and right work fine 100% of the time

* when I'm in the movies screen (with the thumbnails), then left and right go twice on each keypress 80% of the time (indeed sometimes no repeat)

* it seems that up and down keys seem to be working without the double key presses...

 

it's driving me MAD by now....

Share this post


Link to post
Share on other sites

Oh, sorry, it's in the Harmony setup.  The remote by default repeats an IR send up to 3 times (depending on the receiving device), to make sure the command is received.    For the Flirc, it should be set to repeat once, but if you've configured the Flirc as another device it could be more.  I've found the Flirc doesn't need a repeat, and setting repeats to zero has reduced my accidental double-presses.

 

Repeats
The Repeats are the number of times the remote repeats a command for a device to
properly respond to the command. For instance, many devices need longer or shorter
command repetitions to respond properly.


Example:
Any time I press channel up, my Digital Set Top Box skips two channels at a time.
To adjust the Repeats, from the Harmony Remote Software:


Click
1. Troubleshoot at the top of the Harmony Remote Software window.

2. Select the device you want to adjust repeats for, and click Next.
3. Select Device responds to some commands either too many times or only occasionally and click Next
4. Adjust the repeats by selecting a higher or lower number, and click
5. SAVE
 

 

@JAC: uhm.... where is this setting? Harmony? Flirc? Raspbmc?

  • Like 1

Share this post


Link to post
Share on other sites

Hi,

 

Can I just say this happens to me too.  I have Harmony 900 and I'm running openelec on an intel NUC.

 

When I press a direction or enter button on my remote it behaves, on screen, as if I pressed the button about 100 times really fast. 

 

I'm running the Logitech Flirc profile and flirc firmware rc4.

 

Extremely frustrating.  

 

Thanks, Jeremy.

Share this post


Link to post
Share on other sites

Jeremy, I am sorry to hear this, but I am so glad to hear this :)

 

Always great if this one awful problem is not only mine. I have to say I have actually given up by now. Lots of "try this and try that", the "next firmware will solve it", but all to no avail. I was getting so fed up with always having to reprogram and try another theory that I've sort of accepted that I need 2 remotes. One for Flirc and one for the rest. Very annoying.

 

So hopefully you joining the pack will increase the odds of getting this exceptionally annoying problem solved. 

Share this post


Link to post
Share on other sites

Ok I have some good news and some bad news.  The good news is I diagnosed the problem as IR interference/leakage.

 

My harmony 900 has 3 IR blasters.  All my HT equipment is in the same cabinet.  It turns out the FLIRC must've been taking signals from all the IR blasters at once even though they weren't close to each other.

 

To fix my problem I moved the FLIRC and 1 IR Blaster outside of the cabinet so that the other blasters couldn't possibly interfere.  It worked and everything now works perfectly.

 

The bad news (well good news for me) is I no longer have this problem sorry zaphod :-)

Share this post


Link to post
Share on other sites

and just when I thought we were brothers in arms ;)

 

Can you please tell me what "IR Blasters" means? I assume it is the sender of IR signals, which is then "blasted" (many signals through three IR senders?). And what is HT equipment? I don't understand if there is only one device "blasting" (your harmony), how there is interference from anything else. Any info would help, then I can also try your theory...

Share this post


Link to post
Share on other sites

and just when I thought we were brothers in arms ;)

 

Can you please tell me what "IR Blasters" means? I assume it is the sender of IR signals, which is then "blasted" (many signals through three IR senders?). And what is HT equipment? I don't understand if there is only one device "blasting" (your harmony), how there is interference from anything else. Any info would help, then I can also try your theory...

 

Ok so the Harmony 900 sends RF signals to a base unit that converts the RF into IR signals.  The base unit then sends the IR signals out via the mini IR blasters (IR senders).  You place the blasters in front of your Home Theatre (HT) equipment so that your remote can control multiple devices. 

 

I had my home theatre equipment (XBMC box, DVR and Apple TV) all in the same cabinet, each with their own harmony mini-blaster.

The harmony sends the IR signals to ALL of the mini-blasters at the same time.  eg. If I wanted to play a movie on XBMC I'd press "play" on my remote and the harmony would send the IR signal to all of the mini-blasters BUT only the XBMC would react to the play signal because the other devices (DVR and Apple TV) wouldn't recognise the IR signal being sent).

 

The problem for me was because the IR signal is sent to all three mini blasters the FLIRC was picking up the 3 IR signals at the same time causing it to go crazy.  I had to move the flirc to a position where it would only pick up the signal from one IR blaster (not all three).  I did this by moving my XBMC/FLIRC and one IR blaster outside of the cabinet away from the other 2 IR blasters.  This solved my problem instantly.

 

Hope that makes sense.

 

Jeremy.

Share this post


Link to post
Share on other sites

ah, it's one of those fancy harmony's. I now understand. And indeed also understand I'm on my own again since your situation is quite different to mine. Thanks for making the time for your explanation!

Share this post


Link to post
Share on other sites

I use rc 4. With windows 8 and plex everything worked fine. With windows 8.1 and plex one click is two clicks. I use a harmony one. and use method as provided on forum. Program the one as t.v.  

 

I read this topic but have not yet found a solution. Is there a solution? Did i miss it? 

Share this post


Link to post
Share on other sites

So i am having exactly the same problem .. i have a Harmony 700 connected to an Ouya ( Android ) running XBMC. When it is occuring if i pull the FLIRC it immediately stops, so i suspect the FLICR rather that the Harmony. If i use the Bluetooth game pad from the Ouya it woks fine, so i suspect its not an XBMC issue.

 

Agree, very annoying. This is the main thing stopping me retiring the Apple TV in favour of the Ouya.

Share this post


Link to post
Share on other sites

So i am having exactly the same problem .. i have a Harmony 700 connected to an Ouya ( Android ) running XBMC. When it is occuring if i pull the FLIRC it immediately stops, so i suspect the FLICR rather that the Harmony. If i use the Bluetooth game pad from the Ouya it woks fine, so i suspect its not an XBMC issue.

 

Agree, very annoying. This is the main thing stopping me retiring the Apple TV in favour of the Ouya.

Does it exhibit the same behavior in a PC? Let's find out if it's ouya.

Share this post


Link to post
Share on other sites

Does it exhibit the same behavior in a PC? Let's find out if it's ouya.

Hi, so i plugged it into the PC and got the multiple press(s) BUT they seemed to be not as many .. and it came good very quickly. I was then not able to reproduce it again on the PC .. interesting. So i had a look at my OUYA and tried plugging the FLIRC directly into the OUYA instead of via an extension cable .. That did not work at all, the OUYA has all its ports tightly together so i was no really surprised. i then change the USB extension cable from a 1.2M cable to a shorter 90cm ( approx. ) cable.  The problem has not appeared since .. so MAYBE its an interference type issue. I will report back in a week or so with an update, but looks promising, use short and good quality USB extension cables may be the advice.

 

Cheers

Share this post


Link to post
Share on other sites

I have a Harmony One RC and I'm getting occasional stuck auto-repeat,  just wondering where this is controlled from?

is it on the FLIRC device or my Linux config?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×