Jump to content
Flirc Forums

Flirc makes Ubuntu fail BOOT!


dronnen
 Share

Recommended Posts

*** SOLVED ****  :)  :)  :)  :) 

Hello.

I have recently bought a flirc.

My setup is a Zotac Zbox, with the latest Xbmcbuntu installed. I have programmed my flirc, and it works just fine.

BUT, here comes the problem.

If I power ON the mediacenter WITH the Flirc inside the USB port, the system fails to boot. The screen just stays black!

If I remove the Flirc, and restart the mediacenter WITHOUT the Flirc, the system boots just fine!

I can put in the Flirc in the USB after XBMC has loaded up, and my device works just fine.

What is the reason it makes my box fail the boot ? Is it because it detects Flirc as an bootable device?

Please help me.

Thank you for any answers. :)

  • Like 1
Link to comment
Share on other sites

okey.

 

How do I change boot priority in xbmcbuntu ? I cannot enter the boot menu. (With the Flirc device plugged in, I cannot get into the BIOS. If I unplug the Flirc I can enter the Bios, but under boot priority, it ONLY lists my Sata drive.

 

Anyone?.

Link to comment
Share on other sites

Yep, you'll want to make the sata drive the primary (or master) boot drive. Then all other devices mounted should be the 2nd, 3rd etc option.

 

Take a picture of the bios screen if you're still struggling, post it in this thread and we'll help :)

Link to comment
Share on other sites

  • 2 weeks later...

Yep, you'll want to make the sata drive the primary (or master) boot drive. Then all other devices mounted should be the 2nd, 3rd etc option.

 

Take a picture of the bios screen if you're still struggling, post it in this thread and we'll help :)

 

Hello.

 

Sry for my late response.

 have been quite busy, and I almost forgot about my Flirc device.

 

I have made a video showing my problem very clearly.

 

Video of the boot FAIL:

Shows that Flirc makes the mediacenter NOT boot, and without it, boot's just fine!

 

Video of ERROR msg:

(Shows up when the Flirc device is NOT plugged in, and mediacenter still boots up)

 

Screenshot of ERROR msg:

It says "Stopping remote control daemon(s): LIRC (I guess this should be Flirc ? or its and process or something ?

http://img209.imageshack.us/img209/7163/j5fb.jpg

 

ALSO! 

Video from all menues in my bios:

 

 

 

Please: Does anyone know how to fix this error ?

 

Any help is appreciated :)

-Dronn1

Link to comment
Share on other sites

Wow this really is a puzzler. I've just re-watched your videos and it really does mess things up - it doesn't compain that there is no OS on Flirc, it just sits there.

 

Screenshot of ERROR msg:

It says "Stopping remote control daemon(s): LIRC (I guess this should be Flirc ? or its and process or something ?

Shouldn't be as Flirc doesn't use LIRC. All that is on the device itself - it just turns up as a USB keyboard.

 

 

One thing I did perhaps notice (or couldn't see correctly) - the initial bootloader part (zotac screen) is really quick.

How did you get into the BIOS settings before?

When do you press the key combo for the BIOS screen, when the zotac boot image is shown?

Link to comment
Share on other sites

Wow this really is a puzzler. I've just re-watched your videos and it really does mess things up - it doesn't compain that there is no OS on Flirc, it just sits there.

 

Shouldn't be as Flirc doesn't use LIRC. All that is on the device itself - it just turns up as a USB keyboard.

 

 

One thing I did perhaps notice (or couldn't see correctly) - the initial bootloader part (zotac screen) is really quick.

How did you get into the BIOS settings before?

When do you press the key combo for the BIOS screen, when the zotac boot image is shown?

 

Yeah this is a puzzle :)

 

I press the F11 key WHEN the zotac boot image shows. 

 

I have replied to your post on youtube, I am NOT able to get into the BIOS when the Flirc device is plugged in.

Link to comment
Share on other sites

The problem lies in that you can get into the bios menu with flirc plugged in. If you could then it would show up in the boot menu (

seconds in).

 

Do you have a USB memory stick, does that cause booting up to fail. It might be worth emailing ZOTAC to see if they have any tidbits of information

 

I've never seen anything thing like the issue you're having as bios is always accessible - it's just one of those things like gravity always keeping you on the ground.

Link to comment
Share on other sites

******SOLVED****  :)  :)  :)  :)  :) 
 
 
 
FINALLY!!! It works. 
 
I disabled the USB legacy support, and got it to boot with the FLirc device. But after several tries, I found out that it wasnt the Usb legacy support that was the problem!
It was the keyboard I used for BIOS management that was plugged in, making the whole computer to freeze, when the keyboard AND the FLIRC device was plugged in at the same time! Booting with just one of them works fine!
 
 
 
Thanks for all the help lads! Cheers.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...